mirror of https://github.com/openwrt/openwrt.git
ethtool: update to 6.14
Version 6.14 - April 7, 2025 * Feature: list PHYs (--show-phys) * Feature: target a specific PHY with some commands (--phy) * Feature: more attributes for C33 PSE (--show-pse, --set-pse) * Feature: source information for cable tests (--cable-test[-tdr]) * Feature: JSON output for module info (-m) * Feature: misc RSS hash info improvements (-x) * Feature: tsinfo hwtstamp provider (--{get,set}-hwtimestamp-cfg) * Fix: fix wrong auto-negotiation state (no option) * Fix: more explicit RSS context action (-n) * Fix: print PHY address as decimal (no option) * Fix: fix return value on flow hashing error (-N) * Fix: fix JSON output for IRQ coalescing * Fix: fix MDI-X info output (no option) * Misc: code cleanup in module parsers * Misc: provide module_info JSON schema * Misc: add '-j' alias for --json * Misc: provide AppStream metainfo XML * Misc: update message descriptions for debugging output Signed-off-by: Piotr Kubik <piotr.kubik@adtran.com> Signed-off-by: Chad Monroe <chad@monroe.io> Link: https://github.com/openwrt/openwrt/pull/18803 Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
0d4eda6237
commit
08179b367b
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ethtool
|
||||
PKG_VERSION:=6.11
|
||||
PKG_VERSION:=6.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
|
||||
PKG_HASH:=8d91f5c72ae3f25b7e88d4781279dcb320f71e30058914370b1c574c96b31202
|
||||
PKG_HASH:=9338bb00e492878d3bbe3cd2894e60db35813634c208db0b20f5c7ee84da69b1
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -37,19 +37,24 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|||
[Install the bash-completion script in this directory. @<:@default=yes@:>@]),
|
||||
--- a/ethtool.c
|
||||
+++ b/ethtool.c
|
||||
@@ -4109,9 +4109,11 @@ static int do_grxfh(struct cmd_context *
|
||||
(const char *)hfuncs->data + i * ETH_GSTRING_LEN,
|
||||
(rss->hfunc & (1 << i)) ? "on" : "off");
|
||||
|
||||
@@ -4114,7 +4114,7 @@ static int do_grxfh(struct cmd_context *
|
||||
}
|
||||
if (rss->hfunc)
|
||||
printf(" Unknown hash function: 0x%x\n", rss->hfunc);
|
||||
-
|
||||
+#ifdef ETHTOOL_ENABLE_RSS_INPUT_XFRM
|
||||
printf("RSS input transformation:\n");
|
||||
printf(" symmetric-xor: %s\n",
|
||||
(rss->input_xfrm & RXH_XFRM_SYM_XOR) ? "on" : "off");
|
||||
@@ -4123,6 +4123,7 @@ static int do_grxfh(struct cmd_context *
|
||||
if (rss->input_xfrm)
|
||||
printf(" Unknown bits in RSS input transformation: 0x%x\n",
|
||||
rss->input_xfrm);
|
||||
+#endif
|
||||
|
||||
out:
|
||||
free(hfuncs);
|
||||
@@ -4431,7 +4433,15 @@ static int do_srxfh(struct cmd_context *
|
||||
@@ -4442,7 +4443,15 @@ static int do_srxfh(struct cmd_context *
|
||||
rss->cmd = ETHTOOL_SRSSH;
|
||||
rss->rss_context = rss_context;
|
||||
rss->hfunc = req_hfunc;
|
||||
|
|
Loading…
Reference in New Issue