dante: update to 1.4.4
Refreshed patches. Use libtirpc to fix missing bindresvport. It's not actually used. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
806b524a28
commit
0a5786e15e
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dante
|
||||
PKG_VERSION:=1.4.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.4.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.inet.no/dante/files/
|
||||
PKG_HASH:=418a065fe1a4b8ace8fbf77c2da269a98f376e7115902e76cda7e741e4846a5d
|
||||
PKG_HASH:=1973c7732f1f9f0a4c0ccf2c1ce462c7c25060b25643ea90f9b98f53a813faec
|
||||
|
||||
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
||||
PKG_LICENSE:=BSD-4-Clause
|
||||
|
@ -21,6 +21,7 @@ PKG_LICENSE:=BSD-4-Clause
|
|||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=USE_MUSL:libtirpc
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -30,8 +31,9 @@ CONFIGURE_ARGS += \
|
|||
--disable-libwrap
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_search_pam_start="" \
|
||||
ac_cv_func_sched_setscheduler=no
|
||||
ac_cv_search_pam_start=""
|
||||
|
||||
TARGET_CFLAGS += $(if $(CONFIG_USE_MUSL),-I"$(STAGING_DIR)/usr/include/tirpc")
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
|
|
|
@ -8,48 +8,3 @@
|
|||
#include <pthread.h>
|
||||
#endif /* HAVE_PTHREAD_H */
|
||||
|
||||
--- a/lib/Rbindresvport.c
|
||||
+++ b/lib/Rbindresvport.c
|
||||
@@ -72,11 +72,11 @@ Rbindresvport(s, _sin)
|
||||
|
||||
if (_sin == NULL) {
|
||||
slog(LOG_DEBUG, "%s: fd %d, _sin = %p", function, s, _sin);
|
||||
- return bindresvport(s, _sin);
|
||||
+ return Rbindresvport(s, _sin);
|
||||
}
|
||||
|
||||
usrsockaddrcpy(&sin, TOSS(_sin), sizeof(*_sin));
|
||||
- if (bindresvport(s, TOIN(&sin)) != 0) {
|
||||
+ if (Rbindresvport(s, TOIN(&sin)) != 0) {
|
||||
slog(LOG_DEBUG, "%s: bindresvport(%d, %s) failed: %s",
|
||||
function,
|
||||
s,
|
||||
--- a/lib/Rconnect.c
|
||||
+++ b/lib/Rconnect.c
|
||||
@@ -433,7 +433,7 @@ Rconnect(s, _name, namelen)
|
||||
TOIN(&socksfd.local)->sin_port = htons(0);
|
||||
|
||||
/* LINTED pointer casts may be troublesome */
|
||||
- bindresvport(s, TOIN(&socksfd.local));
|
||||
+ Rbindresvport(s, TOIN(&socksfd.local));
|
||||
}
|
||||
|
||||
return Rconnect(s, TOSA(&name), namelen);
|
||||
--- a/libscompat.m4
|
||||
+++ b/libscompat.m4
|
||||
@@ -34,6 +34,7 @@ AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <net/if.h>
|
||||
#ifndef SIOCGIFHWADDR
|
||||
@@ -103,6 +104,7 @@ AC_CHECK_FUNC(getpassphrase,
|
||||
|
||||
AC_MSG_CHECKING([for sched_setaffinity])
|
||||
AC_TRY_COMPILE([
|
||||
+#define _GNU_SOURCE
|
||||
#include <sched.h>
|
||||
],
|
||||
[ cpu_set_t set1;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -1106,6 +1106,8 @@ changequote([, ])dnl
|
||||
@@ -1097,6 +1097,8 @@ changequote([, ])dnl
|
||||
dnl test function that tries to determine if a specified errno error exists
|
||||
m4_define([checkerrno],
|
||||
[AC_MSG_CHECKING(for errno symbol $3)
|
||||
|
@ -9,7 +9,7 @@
|
|||
AC_PREPROC_IFELSE(
|
||||
[AC_LANG_PROGRAM([[#include <errno.h>]],
|
||||
[[
|
||||
@@ -1117,7 +1119,8 @@ errnoval: $3
|
||||
@@ -1108,7 +1110,8 @@ errnoval: $3
|
||||
[AC_MSG_RESULT([OK])
|
||||
$1="$$1 $3"
|
||||
cat conftest.i | grep errnoval: >>$2],
|
||||
|
@ -19,7 +19,7 @@
|
|||
AC_DEFUN([L_CHECKERRNO],
|
||||
[checkerrno($@)])
|
||||
|
||||
@@ -1127,6 +1130,8 @@ dnl error exists
|
||||
@@ -1118,6 +1121,8 @@ dnl error exists
|
||||
dnl test function that tries to determine if a specified errno error exists
|
||||
m4_define([checkgaierror],
|
||||
[AC_MSG_CHECKING(for getaddrinfo() error $3)
|
||||
|
@ -28,7 +28,7 @@
|
|||
AC_PREPROC_IFELSE(
|
||||
[AC_LANG_PROGRAM([[
|
||||
#include <sys/types.h>
|
||||
@@ -1142,7 +1147,8 @@ gaierrval: $3
|
||||
@@ -1133,7 +1138,8 @@ gaierrval: $3
|
||||
$1="$$1 $3"
|
||||
AC_DEFINE(HAVE_ERR_$3, 1, [$3 gai error found])
|
||||
cat conftest.i | grep gaierrval: >>$2],
|
||||
|
|
|
@ -34,5 +34,5 @@
|
|||
+#endif
|
||||
+
|
||||
static const char rcsid[] =
|
||||
"$Id: address.c,v 1.288.4.4.6.4 2020/11/11 17:02:23 karls Exp $";
|
||||
"$Id: address.c,v 1.288.4.4.6.4.4.1 2024/11/21 10:22:42 michaels Exp $";
|
||||
|
||||
|
|
Loading…
Reference in New Issue