knxd: bump to version 0.14.68

Signed-off-by: Othmar Truniger <github@truniger.ch>
This commit is contained in:
Othmar Truniger 2024-12-15 13:24:52 +01:00 committed by Hannu Nyman
parent bba5282ff6
commit 0d478f6508
3 changed files with 13 additions and 3 deletions

View File

@ -11,12 +11,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knxd
PKG_VERSION:=0.14.67
PKG_VERSION:=0.14.68
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/knxd/knxd/tar.gz/$(PKG_VERSION)?
PKG_HASH:=1d6290e576b079d9e751b63bd8fe9c627820d2b6a04ec811ff0b5fcc2c688abf
PKG_HASH:=49de6adddab53b73302560fe1c2bdacc0b71ffe980bd8fdc94dbff97e15ce2e1
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
PKG_LICENSE:=GPL-2.0-or-later

View File

@ -7,4 +7,4 @@
-test -d .git || exit
-# git describe --tags
-git log --format=format:%D | perl -ne 'next unless s#.*tag: ##; s#,.*##; next if m#/#; print; exit;'
+echo -n "0.14.67"
+echo -n "0.14.68"

View File

@ -0,0 +1,10 @@
--- a/src/libserver/tcptunserver.cpp
+++ b/src/libserver/tcptunserver.cpp
@@ -21,6 +21,7 @@
#include "config.h"
#include "tunchannel.h"
+#include <unistd.h>
#include <netinet/tcp.h>
#include <sys/un.h>
#include <arpa/inet.h>