Merge pull request #1145 from emabo/master
openvswitch: upgrade to version 2.3.90
This commit is contained in:
commit
105910ea0f
|
@ -11,8 +11,8 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=openvswitch
|
||||
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.3.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.3.90
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -21,9 +21,11 @@ PKG_USE_MIPS16:=0
|
|||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/openvswitch/ovs
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=0dfed4ba9c8a16a1f316d709b7831a4e139472d4
|
||||
PKG_SOURCE_VERSION:=58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
SUPPORTED_KERNELS:=LINUX_3_18||LINUX_4_0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
$(call include_mk, python-package.mk)
|
||||
|
@ -50,8 +52,7 @@ endef
|
|||
define Package/openvswitch
|
||||
$(call Package/openvswitch/Default)
|
||||
TITLE:=Open vSwitch Userspace Package
|
||||
DEPENDS:=+libpcap +libopenssl +librt +libatomic +kmod-openvswitch \
|
||||
@(LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
|
||||
DEPENDS:=+libpcap +libopenssl +librt +libatomic +kmod-openvswitch @(SUPPORTED_KERNELS)
|
||||
endef
|
||||
|
||||
define Package/openvswitch/description
|
||||
|
@ -95,8 +96,7 @@ define KernelPackage/openvswitch
|
|||
SUBMENU:=Network Support
|
||||
TITLE:=Open vSwitch Kernel Package
|
||||
KCONFIG:=CONFIG_BRIDGE
|
||||
DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan \
|
||||
@(LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
|
||||
DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @(SUPPORTED_KERNELS)
|
||||
FILES:= \
|
||||
$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,21,openvswitch)
|
||||
|
@ -149,10 +149,10 @@ define Package/openvswitch/install
|
|||
$(INSTALL_BIN) ./files/etc/init.d/openvswitch.init $(1)/etc/init.d/openvswitch
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow-$(PKG_VERSION).so $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch-$(PKG_VERSION).so $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto-$(PKG_VERSION).so $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb-$(PKG_VERSION).so $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb.so* $(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-appctl $(1)/usr/bin/
|
||||
|
|
|
@ -14,7 +14,7 @@ diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
|||
index 9bdbbdf..9eaac33 100644
|
||||
--- a/lib/netdev-linux.c
|
||||
+++ b/lib/netdev-linux.c
|
||||
@@ -2566,7 +2566,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
@@ -2709,7 +2709,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
enum netdev_flags on, enum netdev_flags *old_flagsp)
|
||||
OVS_REQUIRES(netdev->mutex)
|
||||
{
|
|
@ -21,7 +21,7 @@ diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
|||
index 9eaac33..423e72e 100644
|
||||
--- a/lib/netdev-linux.c
|
||||
+++ b/lib/netdev-linux.c
|
||||
@@ -2569,7 +2569,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
@@ -2712,7 +2712,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
unsigned int old_flags, new_flags;
|
||||
int error = 0;
|
||||
|
|
@ -1,36 +0,0 @@
|
|||
From 34b51e26555d05c00b2320f943a645added5dae4 Mon Sep 17 00:00:00 2001
|
||||
From: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||
Date: Mon, 9 Dec 2013 14:15:11 +0100
|
||||
Subject: [PATCH 5/6] lib/util.h: Disable ovs_assert when build with NDEBUG
|
||||
|
||||
Reduces binary size. Use a static inline function instead of
|
||||
a macro to not get "unused variable" warning everywhere.
|
||||
|
||||
Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||
---
|
||||
lib/util.h | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/lib/util.h b/lib/util.h
|
||||
index 5c23962..9e5866d 100644
|
||||
--- a/lib/util.h
|
||||
+++ b/lib/util.h
|
||||
@@ -69,10 +69,15 @@
|
||||
* - Writes the failure message to the log.
|
||||
*
|
||||
* - Not affected by NDEBUG. */
|
||||
+#ifndef NDEBUG
|
||||
#define ovs_assert(CONDITION) \
|
||||
if (!OVS_LIKELY(CONDITION)) { \
|
||||
ovs_assert_failure(SOURCE_LOCATOR, __func__, #CONDITION); \
|
||||
}
|
||||
+#else
|
||||
+static inline void ovs_assert(bool cond OVS_UNUSED) {}
|
||||
+#endif
|
||||
+
|
||||
void ovs_assert_failure(const char *, const char *, const char *) NO_RETURN;
|
||||
|
||||
/* Casts 'pointer' to 'type' and issues a compiler warning if the cast changes
|
||||
--
|
||||
1.8.1.4
|
||||
|
|
@ -1,41 +0,0 @@
|
|||
From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Graf <tgraf@noironetworks.com>
|
||||
Date: Wed, 26 Nov 2014 15:52:31 +0100
|
||||
Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS
|
||||
|
||||
This allows users to pass in additional compiler flags through the
|
||||
environment variable EXTRA_CFLAGS, e.g.
|
||||
|
||||
make EXTRA_CFLAGS=-Wno-error=foo V=1
|
||||
|
||||
Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
Signed-off-by: Thomas Graf <tgraf@noironetworks.com>
|
||||
Acked-by: Pravin B Shelar <pshelar@nicira.com>
|
||||
---
|
||||
datapath/linux/Kbuild.in | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in
|
||||
index 6f6f65f..cb98c11 100644
|
||||
--- a/datapath/linux/Kbuild.in
|
||||
+++ b/datapath/linux/Kbuild.in
|
||||
@@ -7,11 +7,11 @@ export VERSION = @VERSION@
|
||||
include $(srcdir)/../Modules.mk
|
||||
include $(srcdir)/Modules.mk
|
||||
|
||||
-EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\"
|
||||
-EXTRA_CFLAGS += -I$(srcdir)/..
|
||||
-EXTRA_CFLAGS += -I$(builddir)/..
|
||||
-EXTRA_CFLAGS += -g
|
||||
-EXTRA_CFLAGS += -include $(builddir)/kcompat.h
|
||||
+ccflags-y := -DVERSION=\"$(VERSION)\"
|
||||
+ccflags-y += -I$(srcdir)/..
|
||||
+ccflags-y += -I$(builddir)/..
|
||||
+ccflags-y += -g
|
||||
+ccflags-y += -include $(builddir)/kcompat.h
|
||||
|
||||
# These include directories have to go before -I$(KSRC)/include.
|
||||
# NOSTDINC_FLAGS just happens to be a variable that goes in the
|
||||
--
|
||||
2.1.2
|
||||
|
Loading…
Reference in New Issue