mg: fix compilation with GCC 14
Addressing compile errors with gcc-14 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
This commit is contained in:
parent
e28bd51cab
commit
1e81025af7
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mg
|
||||
PKG_VERSION:=7.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/ibara/mg/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
|
||||
|
|
|
@ -0,0 +1,10 @@
|
|||
--- a/main.c
|
||||
+++ b/main.c
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <unistd.h>
|
||||
#if defined(__linux__) || defined(__CYGWIN__)
|
||||
#include <pty.h>
|
||||
+#include <utmp.h>
|
||||
#elif defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
|
||||
#include <util.h>
|
||||
#else
|
Loading…
Reference in New Issue