screen: fix compilation with GCC 14

Missing header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2024-05-12 20:44:01 -07:00
parent c3e2dcc128
commit 289bc496ff
2 changed files with 11 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=screen
PKG_VERSION:=4.9.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/screen

View File

@ -0,0 +1,10 @@
--- a/pty.c
+++ b/pty.c
@@ -30,6 +30,7 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <signal.h>
+#include <pty.h>
#if defined(__OpenBSD__)
#include <utils.h> /* for openpty() */