ifstat: fix compilation with GCC14
Need explicit int. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
de110a6e37
commit
2b01007dd4
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ifstat
|
||||
PKG_VERSION:=1.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://gael.roualland.free.fr/ifstat/
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -783,7 +783,7 @@ cat > conftest.$ac_ext << EOF
|
||||
#line 784 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:789: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
ac_cv_prog_cc_works=yes
|
Loading…
Reference in New Issue