bfdd: fix compilation with GCC 10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2020-07-17 16:17:23 -07:00
parent dafbd9e5e4
commit 2bdabc1db7
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with 19 additions and 1 deletions

View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bfdd
PKG_SOURCE_DATE:=2019-08-22
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7
PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)?

View File

@ -0,0 +1,18 @@
--- a/bfd.h
+++ b/bfd.h
@@ -299,13 +299,13 @@ typedef struct bfd_state_str_list_s {
int type;
} bfd_state_str_list;
-struct bfd_vrf {
+extern struct bfd_vrf {
int vrf_id;
char name[MAXNAMELEN + 1];
UT_hash_handle vh;
} bfd_vrf;
-struct bfd_iface {
+extern struct bfd_iface {
int vrf_id;
char ifname[MAXNAMELEN + 1];
UT_hash_handle ifh;