iperf: package update to v3.18

Signed-off-by: Sander <schutten@hotmail.com>
This commit is contained in:
Sander 2025-01-13 12:13:42 +00:00 committed by Rosen Penev
parent 9b847a4e13
commit 3921a981df
4 changed files with 4 additions and 44 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=3.17.1
PKG_RELEASE:=4
PKG_VERSION:=3.18
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.es.net/pub/iperf
PKG_HASH:=84404ca8431b595e86c473d8f23d8bb102810001f15feaf610effd3b318788aa
PKG_HASH:=c0618175514331e766522500e20c94bfb293b4424eb27d7207fb427b88d20bab
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=BSD-3-Clause

View File

@ -10,7 +10,7 @@ iperf_printf is using an int format here but an int64_t variable. The format onl
--- a/src/iperf_api.c
+++ b/src/iperf_api.c
@@ -4056,7 +4056,7 @@ iperf_print_results(struct iperf_test *t
@@ -4137,7 +4137,7 @@ iperf_print_results(struct iperf_test *t
iperf_printf(test, report_sender_not_available_summary_format, "SUM");
}
else {

View File

@ -1,21 +0,0 @@
From 4c7629f590bb18855e478a826833adb05d2a128b Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Sat, 8 Jun 2024 15:35:47 -0700
Subject: [PATCH] fix -Wformat-y2k error
%c potentially prints a 2 digit year. Just use a normal format.
---
src/iperf_error.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/src/iperf_error.c
+++ b/src/iperf_error.c
@@ -99,7 +99,7 @@ iperf_errexit(struct iperf_test *test, c
if (test != NULL && test->timestamps) {
time(&now);
ltm = localtime(&now);
- strftime(iperf_timestrerr, sizeof(iperf_timestrerr), "%c ", ltm);
+ strftime(iperf_timestrerr, sizeof(iperf_timestrerr), "%Y-%m-%d %H:%M:%S", ltm);
ct = iperf_timestrerr;
}

View File

@ -1,19 +0,0 @@
From 3da07ae96f5b40f76b75e1ccd4b20267f6a5988e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jakub=20Kul=C3=ADk?= <kulikjak@gmail.com>
Date: Wed, 28 Aug 2024 09:43:04 +0200
Subject: [PATCH] remove incorrect freeaddrinfo call
---
src/net.c | 1 -
1 file changed, 1 deletion(-)
--- a/src/net.c
+++ b/src/net.c
@@ -145,7 +145,6 @@ create_socket(int domain, int proto, con
if ((gerror = getaddrinfo(server, portstr, &hints, &server_res)) != 0) {
if (local)
freeaddrinfo(local_res);
- freeaddrinfo(server_res);
return -1;
}