nvme-cli: update to 1.12
Bump to latest upstream release. Removed upstreamed: 021-pligins-netapp-add-include-of-libgen.h-for-basename.patch Manually rebased: 010-gcc14.patch Build system: x86/64 Build-tested: x86/64 Run-tested: x86/64 Signed-off-by: John Audia <therealgraysky@proton.me>
This commit is contained in:
parent
6acc8a8651
commit
3b68d2b60d
|
@ -5,12 +5,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nvme-cli
|
||||
PKG_VERSION:=2.11
|
||||
PKG_VERSION:=2.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/linux-nvme/nvme-cli/archive/refs/tags/v$(PKG_VERSION)
|
||||
PKG_HASH:=5e4dc73dbb488c6b1e6ad1c78d0c62b624076fcb0c052bd9039674a1dbd6517b
|
||||
PKG_HASH:=bb6528d0528ccf5d05fbe8e90b82b7632cc0896ffcbe2f4c823ff2de1e79693e
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -4,8 +4,8 @@
|
|||
|
||||
capacity = le64_to_cpu(smart->raw_ns.nsze) * lba;
|
||||
|
||||
- snprintf(tempbuff, sizeof(tempbuff), "log;%s;%lu;%s;%s;%-.*s;", smart->raw_ctrl.sn, smart->time_stamp, smart->path,
|
||||
+ snprintf(tempbuff, sizeof(tempbuff), "log;%s;%" PRId64 ";%s;%s;%-.*s;", smart->raw_ctrl.sn, smart->time_stamp, smart->path,
|
||||
smart->raw_ctrl.mn, (int)sizeof(smart->raw_ctrl.fr), smart->raw_ctrl.fr);
|
||||
strcpy(text, tempbuff);
|
||||
snprintf(tempbuff, sizeof(tempbuff), "Capacity;%lf;", capacity / 1000000000);
|
||||
- snprintf(tempbuff, sizeof(tempbuff), "log;%s;%llu;%s;%s;%-.*s;", smart->raw_ctrl.sn,
|
||||
+ snprintf(tempbuff, sizeof(tempbuff), "log;%s;%" PRId64 ";%s;%s;%-.*s;", smart->raw_ctrl.sn,
|
||||
(unsigned long long)smart->time_stamp, smart->path,
|
||||
smart->raw_ctrl.mn, (int)sizeof(smart->raw_ctrl.fr),
|
||||
smart->raw_ctrl.fr);
|
||||
|
|
|
@ -18,9 +18,9 @@ Signed-off-by: Daniel Néri <dne+commits@rb67.eu>
|
|||
|
||||
--- a/nvme-print.c
|
||||
+++ b/nvme-print.c
|
||||
@@ -797,6 +797,10 @@ static bool is_fahrenheit_country(const
|
||||
return false;
|
||||
}
|
||||
@@ -832,6 +832,10 @@ static bool is_fahrenheit_country(const
|
||||
#define LC_MEASUREMENT LC_ALL
|
||||
#endif
|
||||
|
||||
+#ifndef LC_MEASUREMENT
|
||||
+#define LC_MEASUREMENT LC_ALL
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From ac4818952c872ba465a2d0f48634f9a79aae064f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20N=C3=A9ri?= <dne+commits@rb67.eu>
|
||||
Date: Mon, 11 Nov 2024 22:34:57 +0100
|
||||
Subject: [PATCH] plugins/netapp: add include of libgen.h for basename(3)
|
||||
prototype
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes build with musl libc.
|
||||
|
||||
Signed-off-by: Daniel Néri <dne+commits@rb67.eu>
|
||||
---
|
||||
plugins/netapp/netapp-nvme.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/plugins/netapp/netapp-nvme.c
|
||||
+++ b/plugins/netapp/netapp-nvme.c
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
+#include <libgen.h>
|
||||
|
||||
#include "common.h"
|
||||
#include "nvme.h"
|
Loading…
Reference in New Issue