mailsend: fix compilation with GCC14
Also fix CFLAGS not being passed. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4014c0207e
commit
4471b94ae7
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mailsend
|
PKG_NAME:=mailsend
|
||||||
PKG_VERSION:=1.19
|
PKG_VERSION:=1.19
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/muquit/mailsend/archive/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/muquit/mailsend/archive/$(PKG_VERSION)
|
||||||
|
@ -56,8 +56,18 @@ define Package/mailsend-nossl/description
|
||||||
Mailsend is a simple command line program to send mail via SMTP protocol.
|
Mailsend is a simple command line program to send mail via SMTP protocol.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += \
|
||||||
|
-DHAVE_CTYPE_H \
|
||||||
|
-DHAVE_FCNTL_H \
|
||||||
|
-DHAVE_STDLIB_H \
|
||||||
|
-DHAVE_STRING_H \
|
||||||
|
-DHAVE_STRINGS_H \
|
||||||
|
-DHAVE_UNISTD_H \
|
||||||
|
-DSTDC_HEADERS \
|
||||||
|
-DTIME_WITH_SYS_TIME
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
$(MAKE) -C $(PKG_BUILD_DIR) DEFS="$(TARGET_CFLAGS)"
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/mailsend/install
|
define Package/mailsend/install
|
||||||
|
|
|
@ -0,0 +1,16 @@
|
||||||
|
--- a/main.c
|
||||||
|
+++ b/main.c
|
||||||
|
@@ -965,8 +965,13 @@ int main(int argc,char **argv)
|
||||||
|
}
|
||||||
|
else if (strncmp("show-mime-types",option+1,9) == 0)
|
||||||
|
{
|
||||||
|
+#ifdef HAVE_OPENSSL
|
||||||
|
show_mime_types();
|
||||||
|
rc = 0;
|
||||||
|
+#else
|
||||||
|
+ (void) fprintf(stderr,"Error: '-show-mime-types' not available, not compiled with OpenSSL\n");
|
||||||
|
+ rc = 1;
|
||||||
|
+#endif
|
||||||
|
goto ExitProcessing;
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in New Issue