python3: Update to 3.11.4, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
e182b15eb7
commit
4627ed7c43
|
@ -8,7 +8,7 @@
|
||||||
# Note: keep in sync with setuptools & pip
|
# Note: keep in sync with setuptools & pip
|
||||||
PYTHON3_VERSION_MAJOR:=3
|
PYTHON3_VERSION_MAJOR:=3
|
||||||
PYTHON3_VERSION_MINOR:=11
|
PYTHON3_VERSION_MINOR:=11
|
||||||
PYTHON3_VERSION_MICRO:=3
|
PYTHON3_VERSION_MICRO:=4
|
||||||
|
|
||||||
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
||||||
|
|
||||||
|
@ -16,4 +16,4 @@ PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
|
||||||
PYTHON3_PIP_PKG_RELEASE:=1
|
PYTHON3_PIP_PKG_RELEASE:=1
|
||||||
|
|
||||||
PYTHON3_SETUPTOOLS_VERSION:=65.5.0
|
PYTHON3_SETUPTOOLS_VERSION:=65.5.0
|
||||||
PYTHON3_PIP_VERSION:=22.3.1
|
PYTHON3_PIP_VERSION:=23.1.2
|
||||||
|
|
|
@ -11,12 +11,12 @@ include $(TOPDIR)/rules.mk
|
||||||
include ../python3-version.mk
|
include ../python3-version.mk
|
||||||
|
|
||||||
PKG_NAME:=python3
|
PKG_NAME:=python3
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
||||||
|
|
||||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||||
PKG_HASH:=8a5db99c961a7ecf27c75956189c9602c968751f11dbeae2b900dbff1c085b5e
|
PKG_HASH:=2f0e409df2ab57aa9fc4cbddfb976af44e4e55bf6f619eee6bc5c2297264a7f6
|
||||||
|
|
||||||
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
||||||
PKG_LICENSE:=PSF-2.0
|
PKG_LICENSE:=PSF-2.0
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -2084,6 +2084,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
@@ -2118,6 +2118,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
||||||
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
||||||
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
||||||
fi
|
fi
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
||||||
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
|
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
|
||||||
-j0 -d $(LIBDEST) -f \
|
-j0 -d $(LIBDEST) -f \
|
||||||
@@ -2111,6 +2112,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
@@ -2145,6 +2146,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
||||||
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
|
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
|
||||||
-j0 -d $(LIBDEST)/site-packages -f \
|
-j0 -d $(LIBDEST)/site-packages -f \
|
||||||
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
||||||
|
|
|
@ -1,17 +1,17 @@
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -20712,7 +20712,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
@@ -23352,7 +23352,7 @@ printf %s "checking ABIFLAGS... " >&6; }
|
||||||
$as_echo "$ABIFLAGS" >&6; }
|
printf "%s\n" "$ABIFLAGS" >&6; }
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
||||||
$as_echo_n "checking SOABI... " >&6; }
|
printf %s "checking SOABI... " >&6; }
|
||||||
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
||||||
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
||||||
$as_echo "$SOABI" >&6; }
|
printf "%s\n" "$SOABI" >&6; }
|
||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -5684,7 +5684,7 @@ AC_SUBST(SOABI)
|
@@ -5683,7 +5683,7 @@ AC_SUBST(SOABI)
|
||||||
AC_MSG_CHECKING(ABIFLAGS)
|
AC_MSG_CHECKING(ABIFLAGS)
|
||||||
AC_MSG_RESULT($ABIFLAGS)
|
AC_MSG_RESULT($ABIFLAGS)
|
||||||
AC_MSG_CHECKING(SOABI)
|
AC_MSG_CHECKING(SOABI)
|
||||||
|
|
|
@ -10,7 +10,7 @@
|
||||||
'_PYTHON_SYSCONFIGDATA_NAME',
|
'_PYTHON_SYSCONFIGDATA_NAME',
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -2077,7 +2077,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
@@ -2111,7 +2111,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
|
||||||
esac; \
|
esac; \
|
||||||
done; \
|
done; \
|
||||||
done
|
done
|
||||||
|
@ -19,7 +19,7 @@
|
||||||
$(DESTDIR)$(LIBDEST); \
|
$(DESTDIR)$(LIBDEST); \
|
||||||
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
||||||
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
||||||
@@ -2239,7 +2239,7 @@ sharedinstall: all
|
@@ -2273,7 +2273,7 @@ sharedinstall: all
|
||||||
--install-scripts=$(BINDIR) \
|
--install-scripts=$(BINDIR) \
|
||||||
--install-platlib=$(DESTSHARED) \
|
--install-platlib=$(DESTSHARED) \
|
||||||
--root=$(DESTDIR)/
|
--root=$(DESTDIR)/
|
||||||
|
@ -30,16 +30,16 @@
|
||||||
# Here are a couple of targets for MacOSX again, to install a full
|
# Here are a couple of targets for MacOSX again, to install a full
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -3262,7 +3262,7 @@ fi
|
@@ -3630,7 +3630,7 @@ fi
|
||||||
fi
|
fi
|
||||||
ac_cv_prog_PYTHON_FOR_REGEN=$with_build_python
|
ac_cv_prog_PYTHON_FOR_REGEN=$with_build_python
|
||||||
PYTHON_FOR_FREEZE="$with_build_python"
|
PYTHON_FOR_FREEZE="$with_build_python"
|
||||||
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH) '$with_build_python
|
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH) '$with_build_python
|
||||||
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata '$with_build_python
|
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata '$with_build_python
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_build_python" >&5
|
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $with_build_python" >&5
|
||||||
$as_echo "$with_build_python" >&6; }
|
printf "%s\n" "$with_build_python" >&6; }
|
||||||
|
|
||||||
@@ -20782,7 +20782,7 @@ fi
|
@@ -23421,7 +23421,7 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -59,7 +59,7 @@
|
||||||
AC_MSG_RESULT([$with_build_python])
|
AC_MSG_RESULT([$with_build_python])
|
||||||
], [
|
], [
|
||||||
AS_VAR_IF([cross_compiling], [yes],
|
AS_VAR_IF([cross_compiling], [yes],
|
||||||
@@ -5742,7 +5742,7 @@ fi],
|
@@ -5741,7 +5741,7 @@ fi],
|
||||||
|
|
||||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||||
AC_SUBST(PY_ENABLE_SHARED)
|
AC_SUBST(PY_ENABLE_SHARED)
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -2129,7 +2129,7 @@ python-config: $(srcdir)/Misc/python-con
|
@@ -2163,7 +2163,7 @@ python-config: $(srcdir)/Misc/python-con
|
||||||
@ # On Darwin, always use the python version of the script, the shell
|
@ # On Darwin, always use the python version of the script, the shell
|
||||||
@ # version doesn't use the compiler customizations that are provided
|
@ # version doesn't use the compiler customizations that are provided
|
||||||
@ # in python (_osx_support.py).
|
@ # in python (_osx_support.py).
|
||||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: Šimon Bořek <simon.borek@nic.cz>
|
||||||
|
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -6186,7 +6186,7 @@ EOF
|
@@ -6824,7 +6824,7 @@ EOF
|
||||||
|
|
||||||
if $CPP $CPPFLAGS conftest.c >conftest.out 2>/dev/null; then
|
if $CPP $CPPFLAGS conftest.c >conftest.out 2>/dev/null; then
|
||||||
PLATFORM_TRIPLET=`grep -v '^#' conftest.out | grep -v '^ *$' | tr -d ' '`
|
PLATFORM_TRIPLET=`grep -v '^#' conftest.out | grep -v '^ *$' | tr -d ' '`
|
||||||
|
|
Loading…
Reference in New Issue