nsutils: fix compilation with GCC14

Missing header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2024-05-15 18:00:18 -07:00
parent e2a3f6e340
commit 4a07db85e8
2 changed files with 11 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nsutils
BASE_VERSION:=0.2
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/rd235/nsutils.git

View File

@ -0,0 +1,10 @@
--- a/nslist.c
+++ b/nslist.c
@@ -25,6 +25,7 @@
#include <stdint.h>
#include <string.h>
#include <ctype.h>
+#include <libgen.h>
#include <limits.h>
#include <dirent.h>
#include <getopt.h>