python-requests: bump to version 2.26.0
This version prefers charset_normalizer instead of chardet. chardet is still usable if available. Dropping patches for idna. Not required anymore. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
be2753a9a1
commit
6379f2a103
|
@ -8,8 +8,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-requests
|
||||
PKG_VERSION:=2.25.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.26.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>, Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
PKG_CPE_ID:=cpe:/a:python-requests:requests
|
||||
|
||||
PYPI_NAME:=requests
|
||||
PKG_HASH:=27973dd4a904a4f13b263a19c866c13b92a39ed1c964655f025f3f8d3d75b804
|
||||
PKG_HASH:=b8aa58f8cf793ffd8782d3d8cb19e66ef36f7aba4353eec859e74678b01b07a7
|
||||
|
||||
include ../pypi.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 9484e13c7da927119fe82794bb5571cec144b6d7 Mon Sep 17 00:00:00 2001
|
||||
From: Naor Livne <naorlivne@gmail.com>
|
||||
Date: Fri, 1 Jan 2021 14:31:14 +0200
|
||||
Subject: [PATCH 1/2] bump idna has version 3.0 was released
|
||||
|
||||
Fixes issue (https://github.com/psf/requests/issues/5710):
|
||||
pkg_resources.ContextualVersionConflict: (idna 3.0 (/usr/lib/python3.9/site-packages), Requirement.parse('idna<3,>=2.5'), {'requests'})
|
||||
Origin of this patch:
|
||||
https://github.com/psf/requests/pull/5711
|
||||
|
||||
---
|
||||
setup.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -43,7 +43,7 @@ packages = ['requests']
|
||||
|
||||
requires = [
|
||||
'chardet>=3.0.2,<5',
|
||||
- 'idna>=2.5,<3',
|
||||
+ 'idna>=2.5,<4',
|
||||
'urllib3>=1.21.1,<1.27',
|
||||
'certifi>=2017.4.17'
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
From d3e00a4958af046879f24de365d5589d861ea6ef Mon Sep 17 00:00:00 2001
|
||||
From: Naor Livne <naorlivne@gmail.com>
|
||||
Date: Tue, 5 Jan 2021 16:31:15 +0200
|
||||
Subject: [PATCH 2/2] Update setup.py
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
|
||||
---
|
||||
setup.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -43,7 +43,8 @@ packages = ['requests']
|
||||
|
||||
requires = [
|
||||
'chardet>=3.0.2,<5',
|
||||
- 'idna>=2.5,<4',
|
||||
+ 'idna>=2.5,<3 ; python_version < "3"',
|
||||
+ 'idna>=2.5,<4 ; python_version >= "3"',
|
||||
'urllib3>=1.21.1,<1.27',
|
||||
'certifi>=2017.4.17'
|
||||
|
Loading…
Reference in New Issue