libtorrent: Update to 0.13.7
Switched to tarball. Should be faster. Codeload is used as the regular tarball is on the rtorrent github page with rtorrent's versioning. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
84197cc5d0
commit
6ba094a415
|
@ -8,15 +8,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libtorrent
|
||||
PKG_VERSION:=0.13.6-git-1
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION).1
|
||||
PKG_VERSION:=0.13.7
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/libtorrent.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=14e793b75dac95c51ad64ff9cd2dc6772b68c625
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=0971c21d0e6b7028bc319e97c82bdb213c17dfc503fc0f89b809e5ed7ce98142
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/rakshasa/libtorrent/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=86b4b1753385aaddf9e59ad94f1292eee5102139eb57520e84d1af2f04693708
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -28,9 +24,9 @@ define Package/libtorrent
|
|||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Rakshasa's BitTorrent library
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
URL:=https://rakshasa.github.io/rtorrent/
|
||||
DEPENDS:=+libopenssl +libsigcxx +zlib
|
||||
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/libtorrent/description
|
||||
|
|
|
@ -1,13 +1,3 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -19,7 +19,6 @@ AC_SUBST(LIBTORRENT_INTERFACE_VERSION_NO
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS(config.h)
|
||||
-AM_PATH_CPPUNIT(1.9.6)
|
||||
|
||||
AC_PROG_CXX
|
||||
|
||||
--- a/scripts/checks.m4
|
||||
+++ b/scripts/checks.m4
|
||||
@@ -96,7 +96,7 @@ AC_DEFUN([TORRENT_CHECK_KQUEUE], [
|
||||
|
|
|
@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
|
|||
index 65e34872..27e33570 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -69,12 +69,15 @@ AC_ARG_ENABLE(openssl,
|
||||
@@ -71,12 +71,15 @@ AC_ARG_ENABLE(openssl,
|
||||
[ --disable-openssl Don't use OpenSSL's SHA1 implementation.],
|
||||
[
|
||||
if test "$enableval" = "yes"; then
|
||||
|
@ -28,7 +28,7 @@ index 65e34872..27e33570 100644
|
|||
else
|
||||
AC_DEFINE(USE_NSS_SHA, 1, Using Mozilla's SHA1 implementation.)
|
||||
fi
|
||||
@@ -85,6 +88,7 @@ AC_ARG_ENABLE(openssl,
|
||||
@@ -87,6 +90,7 @@ AC_ARG_ENABLE(openssl,
|
||||
|
||||
AC_DEFINE(USE_OPENSSL, 1, Using OpenSSL.)
|
||||
AC_DEFINE(USE_OPENSSL_SHA, 1, Using OpenSSL's SHA1 implementation.)
|
||||
|
|
Loading…
Reference in New Issue