rtorrent: update to 0.15.3

Rebase patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2025-05-04 18:18:49 -07:00 committed by Tianling Shen
parent 13a058bed6
commit 6d9d871660
2 changed files with 9 additions and 20 deletions

View File

@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtorrent
PKG_VERSION:=0.9.8
PKG_RELEASE:=2
PKG_VERSION:=0.15.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/rakshasa/rtorrent/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=bc889ce1dde475ec56aa72ae996912ff58723226a4f4256fef4f1f8636d991d4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MIRROR_HASH:=e28a07ff147128369b187e4893a5e2918fec1f0e2d4808ed5a3b95aa9e62d45a
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
@ -32,7 +33,7 @@ define Package/rtorrent/Default
CATEGORY:=Network
TITLE:=BitTorrent client for ncurses
URL:=https://github.com/rakshasa/rtorrent
DEPENDS:=+libcurl +libncurses +libpthread +libopenssl +libstdcpp +zlib
DEPENDS:=+libcurl +libncurses +libatomic +libopenssl +libstdcpp +zlib
endef
define Package/rtorrent/Default/description
@ -68,7 +69,6 @@ CONFIGURE_ARGS += \
--enable-static \
--disable-shared \
--disable-debug \
--with-libcurl="$(STAGING_DIR)/usr" \
--with-ncurses \
$(if $(CONFIG_IPV6),--enable,--disable)-ipv6
@ -76,8 +76,8 @@ ifeq ($(BUILD_VARIANT),rpc)
CONFIGURE_ARGS += --with-xmlrpc-c
endif
TARGET_CXXFLAGS += -faligned-new
TARGET_LDFLAGS += -lcrypto -lz
CONFIGURE_VARS = \
ax_cv_cxx_compile_cxx17=yes
define Package/rtorrent/install
$(INSTALL_DIR) $(1)/usr/bin

View File

@ -1,11 +0,0 @@
--- a/src/display/canvas.h
+++ b/src/display/canvas.h
@@ -48,7 +48,7 @@ class Canvas {
public:
typedef std::vector<Attributes> attributes_list;
- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
~Canvas() { if (!m_isDaemon) { delwin(m_window); } }
void refresh() { if (!m_isDaemon) { wnoutrefresh(m_window); } }