git: update to 2.16.1
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
3b3fed7fb8
commit
856c89082d
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=git
|
PKG_NAME:=git
|
||||||
PKG_VERSION:=2.15.1
|
PKG_VERSION:=2.16.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
||||||
PKG_HASH:=999c90fd7d45066992cdb87dda35bdff6dfc1d01496118ea718dfb866da4045c
|
PKG_HASH:=cfad4337f2fdbfc1e2c8abce5e17e1dd4e1718a34ac2cbe3238fbe2426f2ea19
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -926,7 +926,8 @@ AC_RUN_IFELSE(
|
@@ -925,7 +925,8 @@ AC_RUN_IFELSE(
|
||||||
FILE *f = fopen(".", "r");
|
FILE *f = fopen(".", "r");
|
||||||
return f)]])],
|
return f)]])],
|
||||||
[ac_cv_fread_reads_directories=no],
|
[ac_cv_fread_reads_directories=no],
|
||||||
|
@ -10,7 +10,7 @@
|
||||||
])
|
])
|
||||||
if test $ac_cv_fread_reads_directories = yes; then
|
if test $ac_cv_fread_reads_directories = yes; then
|
||||||
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
||||||
@@ -960,7 +961,8 @@ AC_RUN_IFELSE(
|
@@ -959,7 +960,8 @@ AC_RUN_IFELSE(
|
||||||
if (snprintf(buf, 3, "%s", "12345") != 5
|
if (snprintf(buf, 3, "%s", "12345") != 5
|
||||||
|| strcmp(buf, "12")) return 1]])],
|
|| strcmp(buf, "12")) return 1]])],
|
||||||
[ac_cv_snprintf_returns_bogus=no],
|
[ac_cv_snprintf_returns_bogus=no],
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
])
|
])
|
||||||
if test $ac_cv_snprintf_returns_bogus = yes; then
|
if test $ac_cv_snprintf_returns_bogus = yes; then
|
||||||
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
||||||
@@ -983,7 +985,8 @@ yippeeyeswehaveit
|
@@ -982,7 +984,8 @@ yippeeyeswehaveit
|
||||||
#endif
|
#endif
|
||||||
]),
|
]),
|
||||||
[ac_cv_sane_mode_bits=yes],
|
[ac_cv_sane_mode_bits=yes],
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1197,7 +1197,7 @@ else
|
@@ -1234,7 +1234,7 @@ else
|
||||||
endif
|
endif
|
||||||
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
||||||
ifeq "$(curl_check)" "072200"
|
ifeq "$(curl_check)" "072200"
|
||||||
|
|
Loading…
Reference in New Issue