libtalloc: update to 2.42

Refresh patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2024-06-26 15:16:56 -07:00
parent 351126db4d
commit 88aaa484fd
2 changed files with 17 additions and 6 deletions

View File

@ -6,13 +6,13 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=talloc PKG_NAME:=talloc
PKG_VERSION:=2.3.4 PKG_VERSION:=2.4.2
MAJOR_VERSION:=2 MAJOR_VERSION:=2
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.samba.org/ftp/talloc PKG_SOURCE_URL:=https://www.samba.org/ftp/talloc
PKG_HASH:=179f9ebe265e67e4ab2c26cad2b7de4b6a77c6c212f966903382869f06be6505 PKG_HASH:=85ecf9e465e20f98f9950a52e9a411e14320bc555fa257d87697b7e7a9b1d8a6
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net> PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=LGPL-3.0-or-later PKG_LICENSE:=LGPL-3.0-or-later

View File

@ -1,6 +1,6 @@
--- a/lib/replace/wscript --- a/lib/replace/wscript
+++ b/lib/replace/wscript +++ b/lib/replace/wscript
@@ -429,22 +429,13 @@ def configure(conf): @@ -441,33 +441,13 @@ def configure(conf):
conf.CHECK_FUNCS('prctl dirname basename') conf.CHECK_FUNCS('prctl dirname basename')
@ -16,6 +16,17 @@
- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h', - if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
- checklibc=True): - checklibc=True):
- strlcpy_in_bsd = True - strlcpy_in_bsd = True
- elif conf.env.enable_fuzzing:
- # Just to complicate it more, some versions of Honggfuzz have
- # got strlcpy and strlcat in libc, but not in <string.h>
- # (unless it is there coincidentally, on a BSD). Therefore we
- # can't use CHECK_FUNCS alone to decide whether to add the
- # headers to replace.h.
- #
- # As this is only known to happen on a fuzzing compiler, we'll
- # skip the check when not in fuzzing mode.
- conf.CHECK_HEADERS('bsd/string.h')
-
- if not conf.CHECK_FUNCS('getpeereid'): - if not conf.CHECK_FUNCS('getpeereid'):
- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') - conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'): - if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
@ -29,7 +40,7 @@
conf.CHECK_CODE(''' conf.CHECK_CODE('''
struct ucred cred; struct ucred cred;
@@ -827,9 +818,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL @@ -850,9 +830,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
# look for a method of finding the list of network interfaces # look for a method of finding the list of network interfaces
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']: for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
@ -39,7 +50,7 @@
if conf.CHECK_CODE(''' if conf.CHECK_CODE('''
#define %s 1 #define %s 1
#define NO_CONFIG_H 1 #define NO_CONFIG_H 1
@@ -842,7 +830,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL @@ -865,7 +842,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
#include "tests/getifaddrs.c" #include "tests/getifaddrs.c"
''' % method, ''' % method,
method, method,
@ -48,7 +59,7 @@
addmain=False, addmain=False,
execute=True): execute=True):
break break
@@ -890,7 +878,6 @@ def build(bld): @@ -913,7 +890,6 @@ def build(bld):
break break
extra_libs = '' extra_libs = ''