knot: update to verion 3.4.1
Signed-off-by: Jan Hák <jan.hak@nic.cz>
This commit is contained in:
parent
2c31513386
commit
8bf814c67c
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=knot
|
||||
PKG_VERSION:=3.4.0
|
||||
PKG_VERSION:=3.4.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
|
||||
PKG_HASH:=2730b11398944faa5151c51b0655cf26631090343c303597814f2a57df424736
|
||||
PKG_HASH:=252a2b83a9319a605103f7491d73a881e97c63339d09170ac9d525155fa41b1a
|
||||
|
||||
PKG_MAINTAINER:=Daniel Salzman <daniel.salzman@nic.cz>
|
||||
PKG_LICENSE:=GPL-3.0 LGPL-2.0 0BSD BSD-3-Clause OLDAP-2.8
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
--- a/src/contrib/atomic.h
|
||||
+++ b/src/contrib/atomic.h
|
||||
@@ -41,6 +41,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#include <stdbool.h>
|
||||
+ #include <stddef.h>
|
||||
|
||||
#define ATOMIC_SET(dst, val) __atomic_store_n(&(dst), (val), __ATOMIC_RELAXED)
|
||||
#define ATOMIC_GET(src) __atomic_load_n(&(src), __ATOMIC_RELAXED)
|
||||
@@ -58,6 +59,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#include <stdbool.h>
|
||||
+ #include <stddef.h>
|
||||
|
||||
#define ATOMIC_SET(dst, val) ((dst) = (val))
|
||||
#define ATOMIC_GET(src) (src)
|
Loading…
Reference in New Issue