openzwave: fix compilation with GCC14

Null pointer dereference. This looks like a bug fix actually...

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2024-07-14 11:50:21 -07:00
parent 725c3d687f
commit 9a9f052598
2 changed files with 12 additions and 1 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openzwave
PKG_VERSION:=1.6.1149
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://old.openzwave.com/downloads

View File

@ -0,0 +1,11 @@
--- a/cpp/src/command_classes/AssociationCommandConfiguration.cpp
+++ b/cpp/src/command_classes/AssociationCommandConfiguration.cpp
@@ -183,7 +183,7 @@ namespace OpenZWave
if (Node* node = GetNodeUnsafe())
{
Group* group = node->GetGroup(groupIdx);
- if ( NULL == group)
+ if (group)
{
if (firstReports)
{