node: Do not use shared `abseil-cpp`

Signed-off-by: Austin Lane <vidplace7@gmail.com>
This commit is contained in:
Austin Lane 2024-12-19 16:15:13 -05:00 committed by Alexandru Ardelean
parent 34c79e8d83
commit 9e70d3c5b0
2 changed files with 15 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=node
PKG_VERSION:=22.11.0
PKG_RELEASE:=1
PKG_RELEASE:=2
NODE_MODULE_VERSION:=127
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz

View File

@ -156,3 +156,17 @@
],
'sources': [
'<(V8_ROOT)/third_party/zlib/adler32.c',
@@ -2229,10 +2254,13 @@
'ABSEIL_ROOT': '../../deps/v8/third_party/abseil-cpp',
},
'direct_dependent_settings': {
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
'include_dirs': [
'<(ABSEIL_ROOT)',
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
],
},
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
'include_dirs': [
'<(ABSEIL_ROOT)',
],