hs20: patch hostapd to make use of updated dm_ddf

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
Daniel Golle 2020-12-20 21:43:53 +00:00
parent 20c52fc651
commit b212b108ce
2 changed files with 12 additions and 1 deletions

View File

@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hs20
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git

View File

@ -0,0 +1,11 @@
--- a/hs20/server/spp_server.c
+++ b/hs20/server/spp_server.c
@@ -1329,7 +1329,7 @@ static xml_node_t * spp_get_mo(struct hs
return NULL;
}
- snprintf(fname, sizeof(fname), "%s/spp/dm_ddf-v1_2.dtd", ctx->root_dir);
+ snprintf(fname, sizeof(fname), "%s/spp/dm_ddf-v1_3.dtd", ctx->root_dir);
if (xml_validate_dtd(ctx->xml, tnds, fname, ret_err) == 0)
*valid = 1;
else if (ret_err && *ret_err &&