libv4l: Upgrade to 1.14.2. Adding RDS and CEC components
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
b01d2c5a72
commit
b2b44c9f3e
|
@ -1,7 +1,4 @@
|
|||
#
|
||||
# Copyright (C) 2009-2015 OpenWrt.org
|
||||
# Copyright (C) 2009 David Cooper <dave@kupesoft.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
@ -9,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=v4l-utils
|
||||
PKG_VERSION:=1.10.0
|
||||
PKG_VERSION:=1.14.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.linuxtv.org/downloads/v4l-utils
|
||||
PKG_HASH:=78ead27ee58a701d7c6342303cf4520bdd4a2b88a7813bc99a0b389307e4336b
|
||||
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
|
||||
PKG_HASH:=e6b962c4b1253cf852c31da13fd6b5bb7cbe5aa9e182881aec55123bae680692
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
|
||||
|
@ -89,14 +86,14 @@ define Build/InstallDev
|
|||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libv4l{1,2,convert}.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libv4l{1,2,convert,2rds}.{a,so*} $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libv4l{1,2,convert}.pc $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libv4l{1,2,convert,2rds}.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/libv4l/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libv4l{1,2,convert}.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libv4l{1,2,convert,2rds}.so.* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/libv4l
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libv4l/v4l{1compat,2convert}.so $(1)/usr/lib/libv4l/
|
||||
endef
|
||||
|
@ -106,10 +103,11 @@ define Package/v4l-utils/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/etc/rc_maps.cfg $(1)/etc/
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/rc_keymaps $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{cx18,ivtv}-ctl $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{rds,media,cx18,ivtv}-ctl $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/decode_tm6000 $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ir-keytable $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ir-{ctl,keytable} $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/v4l2-{compliance,ctl,sysfs-path} $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/cec-{compliance,ctl,follower} $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libv4l))
|
||||
|
|
|
@ -1,3 +1,13 @@
|
|||
--- a/utils/v4l2-ctl/v4l2-ctl.cpp
|
||||
+++ b/utils/v4l2-ctl/v4l2-ctl.cpp
|
||||
@@ -46,6 +46,7 @@
|
||||
#include <vector>
|
||||
#include <map>
|
||||
#include <algorithm>
|
||||
+#include <string_iostream>
|
||||
#include <fstream>
|
||||
|
||||
char options[OptLast];
|
||||
--- a/utils/rds-ctl/rds-ctl.cpp
|
||||
+++ b/utils/rds-ctl/rds-ctl.cpp
|
||||
@@ -29,6 +29,7 @@
|
||||
|
@ -18,11 +28,41 @@
|
|||
#include <libv4l2.h>
|
||||
--- a/utils/v4l2-ctl/v4l2-ctl-streaming.cpp
|
||||
+++ b/utils/v4l2-ctl/v4l2-ctl-streaming.cpp
|
||||
@@ -14,6 +14,7 @@
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <sys/mman.h>
|
||||
#include <dirent.h>
|
||||
#include <math.h>
|
||||
+#include <time.h>
|
||||
|
||||
#include "v4l2-ctl.h"
|
||||
#include "v4l-stream.h"
|
||||
--- a/utils/cec-ctl/cec-ctl.cpp
|
||||
+++ b/utils/cec-ctl/cec-ctl.cpp
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <errno.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <stdarg.h>
|
||||
+#include <time.h>
|
||||
#include <cerrno>
|
||||
#include <string>
|
||||
#include <vector>
|
||||
--- a/utils/cec-compliance/cec-compliance.h
|
||||
+++ b/utils/cec-compliance/cec-compliance.h
|
||||
@@ -21,6 +21,7 @@
|
||||
#define _CEC_COMPLIANCE_H_
|
||||
|
||||
#include <stdarg.h>
|
||||
+#include <time.h>
|
||||
#include <cerrno>
|
||||
#include <string>
|
||||
#include <linux/cec-funcs.h>
|
||||
--- a/utils/cec-follower/cec-follower.h
|
||||
+++ b/utils/cec-follower/cec-follower.h
|
||||
@@ -37,6 +37,7 @@
|
||||
#define _CEC_FOLLOWER_H_
|
||||
|
||||
#include <stdarg.h>
|
||||
+#include <time.h>
|
||||
#include <cerrno>
|
||||
#include <string>
|
||||
#include <linux/cec-funcs.h>
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
--- a/utils/v4l2-ctl/v4l2-ctl-common.cpp
|
||||
+++ b/utils/v4l2-ctl/v4l2-ctl-common.cpp
|
||||
@@ -671,15 +671,18 @@ static bool parse_subset(char *optarg)
|
||||
|
||||
static bool parse_next_subopt(char **subs, char **value)
|
||||
{
|
||||
- static char *const subopts[] = {
|
||||
- NULL
|
||||
- };
|
||||
- int opt = getsubopt(subs, subopts, value);
|
||||
+ char *stmp = *subs;
|
||||
+ *value = NULL;
|
||||
|
||||
- if (opt < 0 || *value)
|
||||
+ if (*subs) {
|
||||
+ *subs = strchr(stmp, ',');
|
||||
+ if (*subs)
|
||||
+ *(*subs)++ = 0;
|
||||
+ else *subs = stmp + strlen(stmp);
|
||||
+
|
||||
+ *value = stmp;
|
||||
return false;
|
||||
- fprintf(stderr, "No value given to suboption <%s>\n",
|
||||
- subopts[opt]);
|
||||
+ }
|
||||
return true;
|
||||
}
|
||||
|
Loading…
Reference in New Issue