nss: update to 3.53
also enable parallel build as now is safe Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
8f7687833e
commit
c155685843
|
@ -7,21 +7,21 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nss
|
PKG_NAME:=nss
|
||||||
PKG_VERSION:=3.52
|
PKG_VERSION:=3.53
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
https://download.cdn.mozilla.net/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src \
|
https://download.cdn.mozilla.net/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src \
|
||||||
https://archive.mozilla.org/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src
|
https://archive.mozilla.org/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src
|
||||||
PKG_HASH:=0a0aeb0cdda65ddcb64f746223df58b150f6803f4bfa1a4e876bbe6f9c4c1561
|
PKG_HASH:=08d36dc1a56325f02e626626d4eeab9c4d126dbd99dfaf419b91d0a696f58917
|
||||||
|
|
||||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||||
PKG_LICENCE:=MPL-2.0
|
PKG_LICENCE:=MPL-2.0
|
||||||
PKG_LICENSE_FILES:=nss/COPYING
|
PKG_LICENSE_FILES:=nss/COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:mozilla:network_security_services
|
PKG_CPE_ID:=cpe:/a:mozilla:network_security_services
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=0
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -85,7 +85,6 @@ MAKE_FLAGS += \
|
||||||
SEED_ONLY_DEV_URANDOM=1 \
|
SEED_ONLY_DEV_URANDOM=1 \
|
||||||
NS_USE_GCC=1 \
|
NS_USE_GCC=1 \
|
||||||
FREEBL_NO_DEPEND=1 \
|
FREEBL_NO_DEPEND=1 \
|
||||||
NSS_DISABLE_DBM=1 \
|
|
||||||
NSS_PKIX_NO_LDAP=1 \
|
NSS_PKIX_NO_LDAP=1 \
|
||||||
ALLOW_OPT_CODE_SIZE=1 \
|
ALLOW_OPT_CODE_SIZE=1 \
|
||||||
OPT_CODE_SIZE=1 \
|
OPT_CODE_SIZE=1 \
|
||||||
|
@ -99,6 +98,10 @@ define Build/Prepare
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/nss/coreconf/nsinstall
|
$(MAKE) -C $(PKG_BUILD_DIR)/nss/coreconf/nsinstall
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Build/Compile/Default,nss_build_all)
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/libnss/conffiles
|
define Package/libnss/conffiles
|
||||||
/etc/pki/nssdb
|
/etc/pki/nssdb
|
||||||
endef
|
endef
|
||||||
|
|
|
@ -13,14 +13,13 @@ Description: Adds auto-generated nss.pc and nss-config script, and
|
||||||
diff -Naurp nss-3.28-orig/nss/Makefile nss-3.28/nss/Makefile
|
diff -Naurp nss-3.28-orig/nss/Makefile nss-3.28/nss/Makefile
|
||||||
--- nss-3.28-orig/nss/Makefile 2016-12-21 05:56:27.000000000 -0600
|
--- nss-3.28-orig/nss/Makefile 2016-12-21 05:56:27.000000000 -0600
|
||||||
+++ nss-3.28/nss/Makefile 2016-12-26 22:24:52.695146032 -0600
|
+++ nss-3.28/nss/Makefile 2016-12-26 22:24:52.695146032 -0600
|
||||||
@@ -47,7 +47,7 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
@@ -48,7 +48,6 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
||||||
# (7) Execute "local" rules. (OPTIONAL). #
|
|
||||||
#######################################################################
|
#######################################################################
|
||||||
|
|
||||||
-nss_build_all: build_nspr all latest
|
nss_build_all:
|
||||||
+nss_build_all: all latest
|
- $(MAKE) build_nspr
|
||||||
|
$(MAKE) all
|
||||||
nss_clean_all: clobber_nspr clobber
|
$(MAKE) latest
|
||||||
|
|
||||||
diff -Naurp nss-3.28-orig/nss/config/Makefile nss-3.28/nss/config/Makefile
|
diff -Naurp nss-3.28-orig/nss/config/Makefile nss-3.28/nss/config/Makefile
|
||||||
--- nss-3.28-orig/nss/config/Makefile 1969-12-31 18:00:00.000000000 -0600
|
--- nss-3.28-orig/nss/config/Makefile 1969-12-31 18:00:00.000000000 -0600
|
||||||
|
@ -242,9 +241,13 @@ diff -Naurp nss-3.28-orig/nss/config/nss.pc.in nss-3.28/nss/config/nss.pc.in
|
||||||
diff -Naurp nss-3.28-orig/nss/manifest.mn nss-3.28/nss/manifest.mn
|
diff -Naurp nss-3.28-orig/nss/manifest.mn nss-3.28/nss/manifest.mn
|
||||||
--- nss-3.28-orig/nss/manifest.mn 2016-12-21 05:56:27.000000000 -0600
|
--- nss-3.28-orig/nss/manifest.mn 2016-12-21 05:56:27.000000000 -0600
|
||||||
+++ nss-3.28/nss/manifest.mn 2016-12-26 22:24:12.278991843 -0600
|
+++ nss-3.28/nss/manifest.mn 2016-12-26 22:24:12.278991843 -0600
|
||||||
@@ -10,4 +10,4 @@ IMPORTS = nspr20/v4.8 \
|
@@ -10,7 +10,7 @@ IMPORTS = nspr20/v4.8 \
|
||||||
|
|
||||||
RELEASE = nss
|
RELEASE = nss
|
||||||
|
|
||||||
-DIRS = coreconf lib cmd cpputil gtests
|
-DIRS = coreconf lib cmd cpputil gtests
|
||||||
+DIRS = coreconf lib cmd cpputil gtests config
|
+DIRS = coreconf lib cmd cpputil config
|
||||||
|
|
||||||
|
lib: coreconf
|
||||||
|
cmd: lib
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue