nfs-kernel-server: update to v2.8.3

Update to v2.8.3
Removed upstreamed: 210-patch-for-broken-libnfsimapd-static-and-regex-plugins.patch
Added: 210-nfsdctl.c-add-missing-basename.patch

Build system: x86/64
Build-tested: x86/64
Run-tested: x86/64

Signed-off-by: John Audia <therealgraysky@proton.me>
This commit is contained in:
John Audia 2025-04-11 09:57:51 -04:00 committed by Hannu Nyman
parent f2030e6256
commit c851cf35c5
4 changed files with 31 additions and 41 deletions

View File

@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nfs-kernel-server
PKG_VERSION:=2.8.2
PKG_VERSION:=2.8.3
PKG_RELEASE:=1
PKG_HASH:=a39bbea76ac0ab9e6e8699caf3c308b6b310c20d458e8fa8606196d358e7fb15
PKG_HASH:=11e7c5847a8423a72931c865bd9296e7fd56ff270a795a849183900961711725
PKG_SOURCE_URL:=@KERNEL/linux/utils/nfs-utils/$(PKG_VERSION)
PKG_SOURCE:=nfs-utils-$(PKG_VERSION).tar.xz
@ -166,7 +166,11 @@ HOST_CONFIGURE_VARS += \
RPCSECGSS_CFLAGS=" " \
RPCSECGSS_LIBS=" " \
CONFIG_SQLITE3_TRUE="\#" \
CONFIG_NFSDCLD_TRUE="\#"
CONFIG_NFSDCLD_TRUE="\#" \
ac_cv_lib_event_core_event_base_dispatch=yes \
ac_cv_header_event2_event_h=yes \
c_cv_lib_sqlite3_sqlite3_libversion_number=yes \
libsqlite3_cv_is_recent=yes
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/tools/rpcgen all

View File

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -359,9 +359,6 @@ CPPFLAGS="${nfsutils_save_CPPFLAGS}"
@@ -363,9 +363,6 @@ CPPFLAGS="${nfsutils_save_CPPFLAGS}"
AC_CHECK_HEADER(uuid/uuid.h, ,
AC_MSG_ERROR([Cannot find needed header file uuid/uuid.h. Install libuuid-devel]))
@ -10,7 +10,7 @@
dnl Check for sqlite3
AC_SQLITE3_VERS
@@ -441,9 +438,6 @@ if test "$enable_gss" = yes; then
@@ -445,9 +442,6 @@ if test "$enable_gss" = yes; then
dnl 'gss' requires getnameinfo - at least for gssd_proc.c
AC_CHECK_FUNC([getnameinfo], , [AC_MSG_ERROR([GSSAPI support requires 'getnameinfo' function])])

View File

@ -0,0 +1,22 @@
From fb6601e3a5746013ff4c1fc023f5f49a27fbdf8a Mon Sep 17 00:00:00 2001
From: John Audia <therealgraysky@proton.me>
Date: Fri, 11 Apr 2025 10:11:20 -0400
Subject: [PATCH] nfsdctl.c: add missing basename
Fix an error when cross compiling due to an implicit declaration
of the basename function in the nfsdctl.c file.
---
utils/nfsdctl/nfsdctl.c | 1 +
1 file changed, 1 insertion(+)
--- a/utils/nfsdctl/nfsdctl.c
+++ b/utils/nfsdctl/nfsdctl.c
@@ -4,6 +4,7 @@
#include <config.h>
#endif
+#include <libgen.h>
#include <linux/module.h>
#include <linux/version.h>
#include <netlink/genl/genl.h>

View File

@ -1,36 +0,0 @@
From e29f6e549b7c42ebdf181bb079020c736fce1311 Mon Sep 17 00:00:00 2001
From: Joshua Kaldon <joshua@kaldon.com>
Date: Wed, 15 Jan 2025 04:51:03 -0500
Subject: [PATCH] Patch for broken libnfsimapd static and regex plugins.
It appears that the makefile does not add nfsidmap_common.c in the
sources. nfs-utils (1:2.8.2-1.1~0.1) UNRELEASED; urgency=medium .
Non-maintainer upload. Fix issue with static and regex plugins
missing symbol get_grnam_buflen.
Signed-off-by: Steve Dickson <steved@redhat.com>
---
support/nfsidmap/Makefile.am | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- a/support/nfsidmap/Makefile.am
+++ b/support/nfsidmap/Makefile.am
@@ -40,15 +40,15 @@ nsswitch_la_SOURCES = nss.c nfsidmap_com
nsswitch_la_LDFLAGS = -module -avoid-version
nsswitch_la_LIBADD = ../../support/nfs/libnfsconf.la
-static_la_SOURCES = static.c
+static_la_SOURCES = static.c nfsidmap_common.c
static_la_LDFLAGS = -module -avoid-version
static_la_LIBADD = ../../support/nfs/libnfsconf.la
-regex_la_SOURCES = regex.c
+regex_la_SOURCES = regex.c nfsidmap_common.c
regex_la_LDFLAGS = -module -avoid-version
regex_la_LIBADD = ../../support/nfs/libnfsconf.la
-umich_ldap_la_SOURCES = umich_ldap.c
+umich_ldap_la_SOURCES = umich_ldap.c nfsidmap_common.c
umich_ldap_la_LDFLAGS = -module -avoid-version
umich_ldap_la_LIBADD = -lldap $(KRB5_GSS_LIB) ../../support/nfs/libnfsconf.la