lighttpd: update to lighttpd 1.4.77 release hash

Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
This commit is contained in:
Glenn Strauss 2025-01-10 19:35:23 -05:00 committed by Tianling Shen
parent 5564f0d60d
commit cd4c0ac813
3 changed files with 4 additions and 75 deletions

View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.76
PKG_RELEASE:=2
PKG_VERSION:=1.4.77
PKG_RELEASE:=1
# release candidate ~rcX testing; remove for release
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
PKG_HASH:=8cbf4296e373cfd0cedfe9d978760b5b05c58fdc4048b4e2bcaf0a61ac8f5011
PKG_HASH:=acafabdbfa2267d8b6452d03d85fdd2a66525f3f05a36a79b6645c017f1562ce
PKG_MAINTAINER:=Glenn Strauss <gstrauss@gluelogic.com>
PKG_LICENSE:=BSD-3-Clause

View File

@ -9,7 +9,7 @@ Subject: [PATCH] [meson] mod_webdav_min w/o deps: xml2 sqlite3 uuid
--- a/src/meson.build
+++ b/src/meson.build
@@ -871,6 +871,16 @@ if (host_machine.system() == 'darwin')
@@ -887,6 +887,16 @@ if (host_machine.system() == 'darwin')
plugin_suffix = 'so' # use "so" instead of "dylib"
endif

View File

@ -1,71 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
Date: Sat, 4 May 2024 06:33:16 +0000
Subject: [PATCH] sys-crypto.h: add support for OpenSSL as crypto library
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Each TLS module in lighttpd is built to utilize its corresponding TLS
library. For example, lighttpd's mod_openssl module utilizes OpenSSL,
and its mod_mbedtls module uses mbedTLS.
Separately, the core lighttpd application may employ cryptographic
functions. For efficiency and portability, if lighttpd is compiled with
Nettle, it becomes the default cryptographic library for the base
application. However, each TLS module within lighttpd still relies on
its respective TLS library.
In scenarios where lighttpd is configured with only one TLS library and
without Nettle, the base application adopts the cryptographic functions
from that specific TLS library.
When preparing for Linux distributions, lighttpd might be built with
several TLS modules, where each module uses its designated TLS library.
Presently, lighttpd does not offer a distinct, dedicated option to
select the cryptographic library for the base application.
In contexts like embedded systems, where a single TLS library might be
utilized across the entire base system, specific configurations allow
the use of either mbedTLS or wolfSSL. For these, lighttpd is compiled
with -DFORCE_MBEDTLS_CRYPTO or -DFORCE_WOLFSSL_CRYPTO, respectively.
To extend this capability, let's introduce the FORCE_OPENSSL_CRYPTO
define, enabling lighttpd to also use OpenSSL as an additional
cryptographic library, akin to the existing support for mbedTLS and
wolfSSL.
Suggested-by: Glenn Strauss <gstrauss@gluelogic.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
src/sys-crypto.h | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
--- a/src/sys-crypto.h
+++ b/src/sys-crypto.h
@@ -60,4 +60,24 @@
#endif
#endif
+#ifdef USE_OPENSSL_CRYPTO
+#ifdef FORCE_OPENSSL_CRYPTO
+#undef USE_GNUTLS_CRYPTO
+#undef USE_MBEDTLS_CRYPTO
+#undef USE_NETTLE_CRYPTO
+#undef USE_NSS_CRYPTO
+#undef USE_WOLFSSL_CRYPTO
+#endif
+#endif
+
+#ifdef USE_GNUTLS_CRYPTO
+#ifdef FORCE_GNUTLS_CRYPTO
+#undef USE_MBEDTLS_CRYPTO
+#undef USE_NETTLE_CRYPTO
+#undef USE_NSS_CRYPTO
+#undef USE_OPENSSL_CRYPTO
+#undef USE_WOLFSSL_CRYPTO
+#endif
+#endif
+
#endif