sane-backends: update to 1.3.1

Many changes since 1.0.31. See:

- https://gitlab.com/sane-project/backends/-/releases/1.0.32
- https://gitlab.com/sane-project/backends/-/releases/1.1.1
- https://gitlab.com/sane-project/backends/-/releases/1.2.1
- https://gitlab.com/sane-project/backends/-/releases/1.3.1

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
Luiz Angelo Daros de Luca 2024-06-03 01:58:06 -03:00 committed by Rosen Penev
parent dab1efaf08
commit d17ab93b6c
3 changed files with 7 additions and 53 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
PKG_VERSION:=1.0.32
PKG_RELEASE:=4
PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/104f09c07d35519cc8e72e604f11643f
PKG_HASH:=3a28c237c0a72767086202379f6dc92dbb63ec08dfbab22312cba80e238bb114
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/83bdbb6c9a115184c2d48f1fdc6847db/
PKG_HASH:=aa82f76f409b88f8ea9793d4771fce01254d9b6549ec84d6295b8f59a3879a0c
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
@ -23,6 +23,7 @@ PKG_CPE_ID:=cpe:/a:sane-backends_project:sane-backends
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@ -345,6 +346,7 @@ $(eval $(call SaneBackend,kvs20xx,Panasonic KV-S20xxC USB/SCSI ADF scanners,+lib
$(eval $(call SaneBackend,kvs40xx,Panasonic KV-S40xxC USB/SCSI ADF scanners,+libpthread +libusb-1.0))
$(eval $(call SaneBackend,leo,LEO Technologies scanners))
$(eval $(call SaneBackend,lexmark,Lexmark X1100/X1200 Series scanners,+libusb-1.0))
$(eval $(call SaneBackend,lexmark_x2600,Lexmark X26xx Series series scanners,+libusb-1.0))
$(eval $(call SaneBackend,ma1509,Mustek BearPaw 1200F USB scanner,+libusb-1.0))
$(eval $(call SaneBackend,magicolor,KONICA MINOLTA magicolor scanners,+libusb-1.0))
$(eval $(call SaneBackend,matsushita,Panasonic KV-SS high speed scanners))

View File

@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -451,7 +451,7 @@ target_alias = @target_alias@
@@ -450,7 +450,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@

View File

@ -1,48 +0,0 @@
From 373dceaa36039977db43e5864759f3b080e92d2c Mon Sep 17 00:00:00 2001
From: Ralph Little <skelband@gmail.com>
Date: Mon, 13 Feb 2023 12:32:35 -0800
Subject: [PATCH] scanimage: more generic fix for selecting a common basename
function.
We have been specially including libgen.h to get a version in other
platforms such as macOS and FreeBSD. However, it is dangerous to
make assumptions about which version of basename that we will get.
So this change reverts to asking for the version that modifies the
argument and creates a copy of the arg that we *can* modify.
---
frontend/scanimage.c | 24 +++++++++++++++---------
1 file changed, 15 insertions(+), 9 deletions(-)
--- a/frontend/scanimage.c
+++ b/frontend/scanimage.c
@@ -39,6 +39,7 @@
#include <string.h>
#include <unistd.h>
#include <stdarg.h>
+#include <libgen.h>
#include <sys/types.h>
#include <sys/stat.h>
@@ -1237,7 +1238,21 @@ write_png_header (SANE_Frame format, int
if ((is_gray_profile && color_type == PNG_COLOR_TYPE_GRAY) ||
(is_rgb_profile && color_type == PNG_COLOR_TYPE_RGB))
{
- png_set_iCCP(*png_ptr, *info_ptr, basename(icc_profile), PNG_COMPRESSION_TYPE_BASE, icc_buffer, icc_size);
+ char *icc_profile_cp = strdup(icc_profile);
+ if (icc_profile_cp == NULL)
+ {
+ fprintf(stderr, "Memory allocation failure prevented the setting of PNG ICC profile.\n");
+ }
+ else
+ {
+ png_set_iCCP (*png_ptr,
+ *info_ptr,
+ basename (icc_profile_cp),
+ PNG_COMPRESSION_TYPE_BASE,
+ icc_buffer,
+ icc_size);
+ free(icc_profile_cp);
+ }
}
else
{