python3: Add new package python3-pip
Signed-off-by: Florian Fieber <florian@florianfieber.de>
This commit is contained in:
parent
10294a1d5c
commit
da4d2e49db
|
@ -0,0 +1,60 @@
|
|||
#
|
||||
# Copyright (C) 2014-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python3-pip
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=pip-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pip/
|
||||
PKG_MD5SUM:=3823d2343d9f3aaab21cf9c917710196
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/pip-$(PKG_VERSION)
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
$(call include_mk, python3-package.mk)
|
||||
|
||||
define Package/python3-pip
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=Tool for installing Python $(PYTHON3_VERSION) packages.
|
||||
URL:=https://pip.pypa.io
|
||||
DEPENDS:=+python3 +python3-dev +python3-lib2to3 +python3-setuptools
|
||||
MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/python3-pip/description
|
||||
A tool for installing and managing Python $(PYTHON3_VERSION) packages.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Py3Mod,,\
|
||||
install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
|
||||
--single-version-externally-managed \
|
||||
)
|
||||
endef
|
||||
|
||||
define Py3Package/python3-pip/filespec
|
||||
+|$(PYTHON3_PKG_DIR)
|
||||
-|$(PYTHON3_PKG_DIR)/_vendor/distlib/*.exe
|
||||
-|$(PYTHON3_PKG_DIR)/utils/outdated.py
|
||||
endef
|
||||
|
||||
define Py3Package/python3-pip/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/pip$(PYTHON3_VERSION) $(1)/usr/bin
|
||||
$(LN) pip$(PYTHON3_VERSION) $(1)/usr/bin/pip3
|
||||
endef
|
||||
|
||||
$(eval $(call Py3Package,python3-pip))
|
||||
$(eval $(call BuildPackage,python3-pip))
|
|
@ -0,0 +1,70 @@
|
|||
From 771a1407b15538697a7f38209e40dbbf58828d33 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Fieber <florian@florianfieber.de>
|
||||
Date: Tue, 9 Jun 2015 15:59:04 +0200
|
||||
Subject: [PATCH] Remove self version checking
|
||||
|
||||
Signed-off-by: Florian Fieber <florian@florianfieber.de>
|
||||
---
|
||||
pip/basecommand.py | 10 ----------
|
||||
pip/cmdoptions.py | 10 ----------
|
||||
2 files changed, 20 deletions(-)
|
||||
|
||||
diff --git a/pip/basecommand.py b/pip/basecommand.py
|
||||
index 854d113..c2337a4 100644
|
||||
--- a/pip/basecommand.py
|
||||
+++ b/pip/basecommand.py
|
||||
@@ -22,7 +22,6 @@ from pip.status_codes import (
|
||||
from pip.utils import get_prog, normalize_path
|
||||
from pip.utils.deprecation import RemovedInPip8Warning
|
||||
from pip.utils.logging import IndentingFormatter
|
||||
-from pip.utils.outdated import pip_version_check
|
||||
|
||||
|
||||
__all__ = ['Command']
|
||||
@@ -237,15 +236,6 @@ class Command(object):
|
||||
logger.critical('Exception:', exc_info=True)
|
||||
|
||||
return UNKNOWN_ERROR
|
||||
- finally:
|
||||
- # Check if we're using the latest version of pip available
|
||||
- if (not options.disable_pip_version_check and not
|
||||
- getattr(options, "no_index", False)):
|
||||
- with self._build_session(
|
||||
- options,
|
||||
- retries=0,
|
||||
- timeout=min(5, options.timeout)) as session:
|
||||
- pip_version_check(session)
|
||||
|
||||
return SUCCESS
|
||||
|
||||
diff --git a/pip/cmdoptions.py b/pip/cmdoptions.py
|
||||
index 9a0446a..4fa29d3 100644
|
||||
--- a/pip/cmdoptions.py
|
||||
+++ b/pip/cmdoptions.py
|
||||
@@ -514,15 +514,6 @@ no_clean = partial(
|
||||
default=False,
|
||||
help="Don't clean up build directories.")
|
||||
|
||||
-disable_pip_version_check = partial(
|
||||
- Option,
|
||||
- "--disable-pip-version-check",
|
||||
- dest="disable_pip_version_check",
|
||||
- action="store_true",
|
||||
- default=False,
|
||||
- help="Don't periodically check PyPI to determine whether a new version "
|
||||
- "of pip is available for download. Implied with --no-index.")
|
||||
-
|
||||
# Deprecated, Remove later
|
||||
always_unzip = partial(
|
||||
Option,
|
||||
@@ -560,7 +551,6 @@ general_group = {
|
||||
client_cert,
|
||||
cache_dir,
|
||||
no_cache,
|
||||
- disable_pip_version_check,
|
||||
]
|
||||
}
|
||||
|
||||
--
|
||||
2.6.2
|
||||
|
Loading…
Reference in New Issue