ffmpeg: update to 6.1.2
- Remove 020-ioctl patch - upstreamed - Remove 030-h264-mips patch - implemented slightly different in the upstream - Two remaining patches are unaffected - Fixup CPU type detected as ' ' on x86_64 Signed-off-by: Aleksey Vasilenko <aleksey.vasilenko@gmail.com>
This commit is contained in:
parent
32dec92714
commit
dc43cca733
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ffmpeg
|
||||
PKG_VERSION:=5.1.4
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=6.1.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
|
||||
PKG_HASH:=54383bb890a1cd62580e9f1eaa8081203196ed53bde9e98fb6b0004423f49063
|
||||
PKG_HASH:=3b624649725ecdc565c903ca6643d41f33bd49239922e45c9b1442c63dca4e38
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Ian Leonard <antonlacon@gmail.com>
|
||||
|
||||
|
@ -380,7 +380,7 @@ endef
|
|||
|
||||
|
||||
# Strip off FPU notation
|
||||
REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
|
||||
REAL_CPU_TYPE:=$(call qstrip,$(firstword $(subst +, ,$(CONFIG_CPU_TYPE))))
|
||||
# Fixup cpu types recogized by ffmpeg configure
|
||||
REAL_CPU_TYPE:=$(subst octeonplus,octeon+,$(REAL_CPU_TYPE))
|
||||
|
||||
|
@ -391,7 +391,7 @@ FFMPEG_CONFIGURE:= \
|
|||
--enable-cross-compile \
|
||||
--cross-prefix="$(TARGET_CROSS)" \
|
||||
--arch="$(ARCH)" \
|
||||
$(if $(REAL_CPU_TYPE),--cpu=$(call qstrip,$(REAL_CPU_TYPE)),) \
|
||||
$(if $(REAL_CPU_TYPE),--cpu=$(REAL_CPU_TYPE),) \
|
||||
--target-os=linux \
|
||||
--prefix="/usr" \
|
||||
--pkg-config="pkg-config" \
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
From 9e674b31606c805dd31b4bb754364a72a5877238 Mon Sep 17 00:00:00 2001
|
||||
From: Brad Smith <brad-at-comstyle.com@ffmpeg.org>
|
||||
Date: Sun, 5 May 2024 23:59:47 -0400
|
||||
Subject: [PATCH] lavd/v4l2: Use proper field type for second parameter of
|
||||
ioctl() with BSD's
|
||||
|
||||
The proper type was used until 73251678c83cbe24d08264da693411b166239bc7.
|
||||
|
||||
This covers all of the OS's that currently have V4L2 support, permutations
|
||||
of Linux glibc/musl, Android bionic, FreeBSD, NetBSD, OpenBSD, Solaris.
|
||||
|
||||
Copied from FreeBSD ports patch.
|
||||
|
||||
Signed-off-by: Brad Smith <brad@comstyle.com>
|
||||
Signed-off-by: Marton Balint <cus@passwd.hu>
|
||||
---
|
||||
libavdevice/v4l2.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/libavdevice/v4l2.c
|
||||
+++ b/libavdevice/v4l2.c
|
||||
@@ -106,10 +106,10 @@ struct video_data {
|
||||
int (*open_f)(const char *file, int oflag, ...);
|
||||
int (*close_f)(int fd);
|
||||
int (*dup_f)(int fd);
|
||||
-#ifdef __GLIBC__
|
||||
- int (*ioctl_f)(int fd, unsigned long int request, ...);
|
||||
-#else
|
||||
+#if defined(__sun) || defined(__BIONIC__) || defined(__musl__) /* POSIX-like */
|
||||
int (*ioctl_f)(int fd, int request, ...);
|
||||
+#else
|
||||
+ int (*ioctl_f)(int fd, unsigned long int request, ...);
|
||||
#endif
|
||||
ssize_t (*read_f)(int fd, void *buffer, size_t n);
|
||||
void *(*mmap_f)(void *start, size_t length, int prot, int flags, int fd, int64_t offset);
|
|
@ -1,17 +0,0 @@
|
|||
--- a/libavcodec/mips/cabac.h
|
||||
+++ b/libavcodec/mips/cabac.h
|
||||
@@ -30,6 +30,7 @@
|
||||
#include "libavutil/mips/mmiutils.h"
|
||||
#include "config.h"
|
||||
|
||||
+#ifndef __mips16
|
||||
#define get_cabac_inline get_cabac_inline_mips
|
||||
static av_always_inline int get_cabac_inline_mips(CABACContext *c,
|
||||
uint8_t * const state){
|
||||
@@ -225,4 +226,6 @@ static av_always_inline int get_cabac_by
|
||||
|
||||
return res;
|
||||
}
|
||||
+
|
||||
+#endif
|
||||
#endif /* AVCODEC_MIPS_CABAC_H */
|
Loading…
Reference in New Issue