Merge pull request #11657 from jefferyto/newt-remove-patch
newt: Remove python_init_once.patch
This commit is contained in:
commit
e592c06b08
|
@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=newt
|
||||
PKG_VERSION:=0.52.21
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://releases.pagure.org/newt
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
Author: Alastair McKinstry <mckinstry@debian.org>
|
||||
Description: newtInit() should only be called once
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557960
|
||||
Forwarded: no
|
||||
Last-Updated: 2014-06-11
|
||||
|
||||
--- a/snack.c
|
||||
+++ b/snack.c
|
||||
@@ -377,10 +377,15 @@ static snackWidget * snackWidgetNew (voi
|
||||
}
|
||||
|
||||
static PyObject * initScreen(PyObject * s, PyObject * args) {
|
||||
+ static int init_newt = 1;
|
||||
suspend.cb = NULL;
|
||||
suspend.data = NULL;
|
||||
|
||||
newtInit();
|
||||
+ if (init_newt) {
|
||||
+ newtInit();
|
||||
+ init_newt = 0;
|
||||
+ }
|
||||
newtCls();
|
||||
|
||||
Py_INCREF(Py_None);
|
Loading…
Reference in New Issue