seafile-server: Update to 7.1.4, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
10e67aca45
commit
f350b5620b
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=seafile-ccnet
|
PKG_NAME:=seafile-ccnet
|
||||||
PKG_VERSION:=7.1.3
|
PKG_VERSION:=7.1.4
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/ccnet-server/tar.gz/v$(PKG_VERSION)-server?
|
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/ccnet-server/tar.gz/v$(PKG_VERSION)-server?
|
||||||
PKG_HASH:=148d9b1af9218943de310f3f2e29e542e7279dbfba307a1cdd894bf8b7faf2e8
|
PKG_HASH:=b46508a686e7fe8eb9e1515e5384c7d9aca25cf596ef4b8383646e587f1032eb
|
||||||
|
|
||||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||||
PKG_LICENSE:=AGPL-3.0-only
|
PKG_LICENSE:=AGPL-3.0-only
|
||||||
|
|
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=seafile-seahub
|
PKG_NAME:=seafile-seahub
|
||||||
PKG_VERSION:=7.1.3
|
PKG_VERSION:=7.1.4
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
|
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
|
||||||
PKG_HASH:=a2cf1ad1ff357b06c112f3f80e2e4a2ef109813496c96afc309449f6915e8797
|
PKG_HASH:=921ef4373311c06c1192975a294d7d38c12ac34381a7df19542391fc1d810baf
|
||||||
|
|
||||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
|
|
@ -9,7 +9,7 @@
|
||||||
os.path.join(PROJECT_ROOT, 'seahub/templates'),
|
os.path.join(PROJECT_ROOT, 'seahub/templates'),
|
||||||
],
|
],
|
||||||
'APP_DIRS': True,
|
'APP_DIRS': True,
|
||||||
@@ -630,7 +630,7 @@ CAPTCHA_IMAGE_SIZE = (90, 42)
|
@@ -633,7 +633,7 @@ CAPTCHA_IMAGE_SIZE = (90, 42)
|
||||||
ENABLE_THUMBNAIL = True
|
ENABLE_THUMBNAIL = True
|
||||||
|
|
||||||
# Absolute filesystem path to the directory that will hold thumbnail files.
|
# Absolute filesystem path to the directory that will hold thumbnail files.
|
||||||
|
@ -18,7 +18,7 @@
|
||||||
if os.path.exists(SEAHUB_DATA_ROOT):
|
if os.path.exists(SEAHUB_DATA_ROOT):
|
||||||
THUMBNAIL_ROOT = os.path.join(SEAHUB_DATA_ROOT, 'thumbnail')
|
THUMBNAIL_ROOT = os.path.join(SEAHUB_DATA_ROOT, 'thumbnail')
|
||||||
else:
|
else:
|
||||||
@@ -793,7 +793,7 @@ except ImportError:
|
@@ -829,7 +829,7 @@ except ImportError:
|
||||||
pass
|
pass
|
||||||
else:
|
else:
|
||||||
# In server release, sqlite3 db file is <topdir>/seahub.db
|
# In server release, sqlite3 db file is <topdir>/seahub.db
|
||||||
|
|
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=seafile-server
|
PKG_NAME:=seafile-server
|
||||||
PKG_VERSION:=7.1.3
|
PKG_VERSION:=7.1.4
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seafile-server/tar.gz/v$(PKG_VERSION)-server?
|
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seafile-server/tar.gz/v$(PKG_VERSION)-server?
|
||||||
PKG_HASH:=79f7722a34c304adb78462194e64d6a610bd5ee40def37f4e4cdf5befed44fcd
|
PKG_HASH:=cc5aaf76044f907758a75a43e321fef499482d7b57d9e61d0297a4bba66dcce4
|
||||||
|
|
||||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||||
PKG_LICENSE:=AGPL-3.0-only
|
PKG_LICENSE:=AGPL-3.0-only
|
||||||
|
|
|
@ -1,23 +1,5 @@
|
||||||
--- a/lib/repo.vala
|
--- a/lib/repo.vala
|
||||||
+++ b/lib/repo.vala
|
+++ b/lib/repo.vala
|
||||||
@@ -34,7 +34,7 @@ public class Repo : Object {
|
|
||||||
// data format version
|
|
||||||
public int version { get; set; }
|
|
||||||
|
|
||||||
- public int last_modify { get; set; }
|
|
||||||
+ public int64 last_modify { get; set; }
|
|
||||||
public int64 size { get; set; }
|
|
||||||
public int64 file_count { get; set; }
|
|
||||||
public string last_modifier { get; set; }
|
|
||||||
@@ -46,7 +46,7 @@ public class Repo : Object {
|
|
||||||
public string repo_id { get; set; }
|
|
||||||
public string repo_name { get; set; }
|
|
||||||
public string repo_desc { get; set; }
|
|
||||||
- public int last_modified { get; set; }
|
|
||||||
+ public int64 last_modified { get; set; }
|
|
||||||
|
|
||||||
// Section 2: Encryption related
|
|
||||||
// Members in this section should be set for every Repo object
|
|
||||||
@@ -70,7 +70,7 @@ public class Repo : Object {
|
@@ -70,7 +70,7 @@ public class Repo : Object {
|
||||||
get { return _relay_id; }
|
get { return _relay_id; }
|
||||||
set { _relay_id = value; }
|
set { _relay_id = value; }
|
||||||
|
|
Loading…
Reference in New Issue