at: update to 3.2.5
- Use upstream tarball - Update project URL - Drop obsolete patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>
This commit is contained in:
parent
9043b66e87
commit
f37e815dfd
|
@ -8,14 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=at
|
||||
PKG_VERSION:=3.2.2
|
||||
PKG_VERSION:=3.2.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://salsa.debian.org/debian/at.git
|
||||
PKG_SOURCE_VERSION:=release/3.2.2
|
||||
PKG_MIRROR_HASH=93f7f99c4242dbc5218907981e32f74ddb5e09c5b7922617c8d84c16920f488d
|
||||
PKG_SOURCE:=at_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://software.calhariz.com/at
|
||||
PKG_HASH:=bb066b389d7c9bb9d84a35738032b85c30cba7d949f758192adc72c9477fd3b8
|
||||
|
||||
PKG_MAINTAINER:=Phil Eichinger <phil@zankapfel.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later GPL-3.0-or-later ISC
|
||||
|
@ -28,7 +26,7 @@ define Package/at
|
|||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libelf
|
||||
TITLE:=Delayed job execution and batch processing
|
||||
URL:=http://packages.debian.org/stable/at
|
||||
URL:=https://salsa.debian.org/debian/at
|
||||
endef
|
||||
|
||||
define Package/at/description
|
||||
|
|
|
@ -1,54 +0,0 @@
|
|||
From 7f811d9c4ebc9444e613e251c31d6bf537a24dc1 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Mon, 13 Apr 2015 16:35:30 -0700
|
||||
Subject: [PATCH] remove glibc assumption
|
||||
|
||||
glibc time.h header has an undocumented __isleap macro
|
||||
that we are using anf musl is missing it.
|
||||
Since it is undocumented & does not appear
|
||||
on any other libc, stop using it and just define the macro in
|
||||
locally instead.
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
[patch from: http://patchwork.openembedded.org/patch/91893/ ]
|
||||
Signed-off-by: Phil Eichinger <phil@zankapfel.net>
|
||||
---
|
||||
parsetime.y | 11 +++++++----
|
||||
1 file changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
--- a/parsetime.y
|
||||
+++ b/parsetime.y
|
||||
@@ -14,6 +14,9 @@
|
||||
((y) % 4 == 0 && ((y) % 100 != 0 || (y) % 400 == 0))
|
||||
#endif
|
||||
|
||||
+#define is_leap_year(y) \
|
||||
+ ((y) % 4 == 0 && ((y) % 100 != 0 || (y) % 400 == 0))
|
||||
+
|
||||
struct tm exectm;
|
||||
static int isgmt;
|
||||
static char *tz = NULL;
|
||||
@@ -230,8 +233,8 @@ date : month_name day_number
|
||||
mnum == 12) && dnum > 31)
|
||||
|| ((mnum == 4 || mnum == 6 || mnum == 9 ||
|
||||
mnum == 11) && dnum > 30)
|
||||
- || (mnum == 2 && dnum > 29 && __isleap(ynum+1900))
|
||||
- || (mnum == 2 && dnum > 28 && !__isleap(ynum+1900))
|
||||
+ || (mnum == 2 && dnum > 29 && is_leap_year(ynum+1900))
|
||||
+ || (mnum == 2 && dnum > 28 && !is_leap_year(ynum+1900))
|
||||
)
|
||||
{
|
||||
yyerror("Error in day of month");
|
||||
@@ -274,8 +277,8 @@ date : month_name day_number
|
||||
mnum == 12) && dnum > 31)
|
||||
|| ((mnum == 4 || mnum == 6 || mnum == 9 ||
|
||||
mnum == 11) && dnum > 30)
|
||||
- || (mnum == 2 && dnum > 29 && __isleap(ynum+1900))
|
||||
- || (mnum == 2 && dnum > 28 && !__isleap(ynum+1900))
|
||||
+ || (mnum == 2 && dnum > 29 && is_leap_year(ynum+1900))
|
||||
+ || (mnum == 2 && dnum > 28 && !is_leap_year(ynum+1900))
|
||||
)
|
||||
{
|
||||
yyerror("Error in day of month");
|
|
@ -1,14 +0,0 @@
|
|||
--- a/getloadavg.c
|
||||
+++ b/getloadavg.c
|
||||
@@ -69,8 +69,9 @@ Boston, MA 02110-1301 USA */
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
-#include "lisp.h"
|
||||
-#include "sysfile.h" /* for encapsulated open, close, read, write */
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
+#include <fcntl.h>
|
||||
|
||||
#ifndef HAVE_GETLOADAVG
|
||||
|
Loading…
Reference in New Issue