ripgrep: update to 4.1.1
- Add patch to fix build on riscv64 Signed-off-by: Aleksey Vasilenko <aleksey.vasilenko@gmail.com>
This commit is contained in:
parent
7f976e1602
commit
f73bf31744
|
@ -5,12 +5,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ripgrep
|
||||
PKG_VERSION:=14.1.0
|
||||
PKG_VERSION:=14.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/BurntSushi/ripgrep/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=33c6169596a6bbfdc81415910008f26e0809422fda2d849562637996553b2ab6
|
||||
PKG_HASH:=4dad02a2f9c8c3c8d89434e47337aa654cb0e2aa50e806589132f186bf5c2b66
|
||||
|
||||
PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
|
||||
PKG_LICENSE:=MIT Unlicense
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
From 3c70b9a4900aab74c7643007e2b8127f9d016ed7 Mon Sep 17 00:00:00 2001
|
||||
From: Aleksey Vasilenko <aleksey.vasilenko@gmail.com>
|
||||
Date: Thu, 12 Sep 2024 17:08:36 +0300
|
||||
Subject: [PATCH] switch to tikv-jemallocator
|
||||
|
||||
---
|
||||
Cargo.toml | 4 ++--
|
||||
crates/core/main.rs | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -59,8 +59,8 @@ serde_json = "1.0.23"
|
||||
termcolor = "1.1.0"
|
||||
textwrap = { version = "0.16.0", default-features = false }
|
||||
|
||||
-[target.'cfg(all(target_env = "musl", target_pointer_width = "64"))'.dependencies.jemallocator]
|
||||
-version = "0.5.0"
|
||||
+[target.'cfg(all(target_env = "musl", target_pointer_width = "64"))'.dependencies.tikv-jemallocator]
|
||||
+version = "0.6.0"
|
||||
|
||||
[dev-dependencies]
|
||||
serde = "1.0.77"
|
||||
--- a/crates/core/main.rs
|
||||
+++ b/crates/core/main.rs
|
||||
@@ -37,7 +37,7 @@ mod search;
|
||||
// i686.
|
||||
#[cfg(all(target_env = "musl", target_pointer_width = "64"))]
|
||||
#[global_allocator]
|
||||
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
|
||||
+static ALLOC: tikv_jemallocator::Jemalloc = tikv_jemallocator::Jemalloc;
|
||||
|
||||
/// Then, as it was, then again it will be.
|
||||
fn main() -> ExitCode {
|
Loading…
Reference in New Issue