node: bump to v20.13.1
Update to v20.13.1 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
This commit is contained in:
parent
7875dc041e
commit
fe8b0e85af
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=node
|
PKG_NAME:=node
|
||||||
PKG_VERSION:=v20.12.2
|
PKG_VERSION:=v20.13.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||||
PKG_HASH:=bc57ee721a12cc8be55bb90b4a9a2f598aed5581d5199ec3bd171a4781bfecda
|
PKG_HASH:=a85ee53aa0a5c2f5ca94fa414cdbceb91eb7d18a77fc498358512c14cc6c6991
|
||||||
|
|
||||||
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/internal/modules/cjs/loader.js
|
--- a/lib/internal/modules/cjs/loader.js
|
||||||
+++ b/lib/internal/modules/cjs/loader.js
|
+++ b/lib/internal/modules/cjs/loader.js
|
||||||
@@ -1529,7 +1529,8 @@ Module._initPaths = function() {
|
@@ -1518,7 +1518,8 @@ Module._initPaths = function() {
|
||||||
path.resolve(process.execPath, '..') :
|
path.resolve(process.execPath, '..') :
|
||||||
path.resolve(process.execPath, '..', '..');
|
path.resolve(process.execPath, '..', '..');
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/node.gyp
|
--- a/node.gyp
|
||||||
+++ b/node.gyp
|
+++ b/node.gyp
|
||||||
@@ -1197,6 +1197,7 @@
|
@@ -1214,6 +1214,7 @@
|
||||||
'dependencies': [
|
'dependencies': [
|
||||||
'deps/simdutf/simdutf.gyp:simdutf#host',
|
'deps/simdutf/simdutf.gyp:simdutf#host',
|
||||||
],
|
],
|
||||||
|
|
|
@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
|
||||||
//
|
//
|
||||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||||
// copy of this software and associated documentation files (the
|
// copy of this software and associated documentation files (the
|
||||||
@@ -1337,13 +1338,6 @@ function lookupAndConnect(self, options)
|
@@ -1338,13 +1339,6 @@ function lookupAndConnect(self, options)
|
||||||
hints: options.hints || 0,
|
hints: options.hints || 0,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
--- a/configure.py
|
--- a/node.gyp
|
||||||
+++ b/configure.py
|
+++ b/node.gyp
|
||||||
@@ -1282,7 +1282,6 @@ def configure_node(o):
|
@@ -1215,6 +1215,7 @@
|
||||||
|
'deps/simdutf/simdutf.gyp:simdutf#host',
|
||||||
# Enable branch protection for arm64
|
],
|
||||||
if target_arch == 'arm64':
|
'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||||
- o['cflags']+=['-msign-return-address=all']
|
+ 'cflags!': ['-mbranch-protection=standard'],
|
||||||
o['variables']['arm_fpu'] = options.arm_fpu or 'neon'
|
'include_dirs': [
|
||||||
|
'tools',
|
||||||
if options.node_snapshot_main is not None:
|
'src',
|
||||||
|
|
Loading…
Reference in New Issue