pptpd: update to 1.5.0

Update pptpd "poptop" to 1.5.0 to fix comptability with PPP 2.5.1.

Also refresh patches

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
This commit is contained in:
Chen Minqiang 2024-10-13 13:18:06 +08:00 committed by Hannu Nyman
parent 8bf814c67c
commit 2455bc08b4
3 changed files with 17 additions and 18 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=pptpd PKG_NAME:=pptpd
PKG_VERSION:=1.4.0 PKG_VERSION:=1.5.0
PKG_RELEASE:=6 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/poptop PKG_SOURCE_URL:=@SF/poptop
PKG_HASH:=8fcd8b8a42de2af59e9fe8cbaa9f894045c977f4d038bbd6346a8522bb7f06c0 PKG_HASH:=6a724284b1ce00ea23f7d7608d081843a10c8a8d87d951cb2ea86e70aa1b4e77
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1

View File

@ -1,6 +1,6 @@
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -153,7 +153,7 @@ AUTOMAKE = @AUTOMAKE@ @@ -233,7 +233,7 @@ AUTOMAKE = @AUTOMAKE@
AWK = @AWK@ AWK = @AWK@
CC = @CC@ CC = @CC@
CCDEPMODE = @CCDEPMODE@ CCDEPMODE = @CCDEPMODE@
@ -8,4 +8,4 @@
+CFLAGS = $(COPTS) -fno-builtin -Wall -DSBINDIR='"$(sbindir)"' +CFLAGS = $(COPTS) -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
CPP = @CPP@ CPP = @CPP@
CPPFLAGS = @CPPFLAGS@ CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@ CSCOPE = @CSCOPE@

View File

@ -1,22 +1,21 @@
--- a/bcrelay.c --- a/bcrelay.c
+++ b/bcrelay.c +++ b/bcrelay.c
@@ -667,7 +667,7 @@ static void mainloop(int argc, char **ar @@ -746,7 +746,7 @@ static void mainloop(int argc, char **ar
* there is no need to concern about the physical/link layer header because it is * because it is filled in automatically
* filled in automatically (based on the contents of sa). * (based on the contents of sa).
*/ */
- if ((nrsent = sendto(cur_ifsnr[j].sock_nr, ipp_p, rlen, MSG_DONTWAIT|MSG_TRYHARD, (struct sockaddr *)&sa, salen)) < 0) - if ((nrsent = sendto(cur_ifsnr[j].sock_nr, ipp_p, rlen, MSG_DONTWAIT|MSG_TRYHARD, (struct sockaddr *)&sa, salen)) < 0)
+ if ((nrsent = sendto(cur_ifsnr[j].sock_nr, ipp_p, rlen, MSG_DONTWAIT|MSG_DONTROUTE, (struct sockaddr *)&sa, salen)) < 0) + if ((nrsent = sendto(cur_ifsnr[j].sock_nr, ipp_p, rlen, MSG_DONTWAIT|MSG_DONTROUTE, (struct sockaddr *)&sa, salen)) < 0)
{ {
if (errno == ENETDOWN) { if (errno == ENETDOWN) {
syslog(LOG_NOTICE, "ignored ENETDOWN from sendto(), a network interface was going down?"); syslog(LOG_NOTICE, "ignored ENETDOWN from sendto(), a network interface was going down?");
--- a/compat.c --- a/compat.c
+++ b/compat.c +++ b/compat.c
@@ -11,10 +11,10 @@ @@ -13,9 +13,9 @@
#include "compat.h"
#include "our_syslog.h" #include <string.h>
-#ifndef HAVE_STRLCPY -#ifndef HAVE_STRLCPY
#include <string.h>
#include <stdio.h> #include <stdio.h>
+#ifndef HAVE_STRLCPY +#ifndef HAVE_STRLCPY